If I reboot Ubuntu, then I need to log on each site and into Google Chrome account. What is the reason? My system is Ubuntu 16.04 and Google Chrome 53.0.2785.101 (64-bit).

  • 1
    That means your cookies are getting deleted every time you close Chrome.
    – edwinksl
    Sep 9 '16 at 5:41
  • How I can fix this?
    – Novah
    Sep 9 '16 at 5:44
  • 2
    Did you install Ubuntu on your computer or are you on a live system without persistence? Except for the latter case this is a Chrome issue that has nothing to do with Ubuntu. Sep 9 '16 at 7:40
  • @DavidFoerster I installed Ubuntu on my computer
    – Novah
    Sep 9 '16 at 12:53
  • Asked yesterday! I am having same issue. :-)
    – Paritosh
    Sep 11 '16 at 3:14

Had the same issue. My system is Ubuntu 16.04 and Google Chrome 53.0.2785.101 (64-bit).

Here is my workaround:

  1. Go to Ubuntu System Settings -> Online Accounts
  2. add your Google account there
  3. turned on the switcher (not sure if it is necessary though)
  4. go to Chrome browser and login there again
  5. close the browser window

Note: you must prevent chrome processes from running after closing the window. To do this go to Chrome settings > Advanced settings (at the bottom) > Uncheck 'Continue running background apps when Google Chrome is closed'

Once I did it Chrome stopped dropping authentication after logging out in Ubuntu and also after rebooting

  • @IgorBukin It helped me.
    – Novah
    Sep 12 '16 at 13:01
  • @Novah That was one of the suggestions in chat. I suggested it as a resolution. You said you didn't want it to be associated with your Google account (chat.stackexchange.com/transcript/message/32209536#32209536). Sep 13 '16 at 1:59
  • 1
    Do you have any idea why this might work?
    – corny
    Sep 13 '16 at 13:44
  • Thanks, I only cleared the password of my gnome keyring (not giving ubuntu my google password) and now it also works.
    – corny
    Sep 14 '16 at 8:15
  • Per some comments on the bug report (bugs.chromium.org/p/chromium/issues/detail?id=631171), this probably works because it forces opening of the keyring before Chromium is started. It appears this has a shot of being fixed with Chromium 55. Now the real question is whether we can get Ubuntu to push out Chromium 55 on a more timely basis than its typical Chromium builds. Nov 8 '16 at 14:29

You have to enable this feature in Privacy settings. You can get there by going into Chrome settings:

Enable saving passwords

  1. Click the Chrome menu icon (the three dots on the top right).
  2. Click Settings
  3. Click Show advance settings (new the bottom of the page)
  4. (Under Privacy - Passwords and forms)Place check marks under the following:
    • Enable Autofill to fill out web forms
    • Offer Save your web passwords

Passwords can be saved even with cookies disabled. You can still check your cookie settings with the steps below.

Enable or disable cookies

  1. Click the Chrome menu icon
  2. Click Settings
  3. Click Show advance settings
  4. In the Privacy section, select Content settings
  5. Select Allow local data to be set

If all settings are set for saving passwords and it still fails check the integrity of Chrome's setting by bring it to the defaults with the following steps.

First exit out of Chrome. Then run these commands to temporarily remove the current settings.

$ cd ~/.config
$ mv google-chrome google-chrome.bak

You can get the previous settings back by renaming google-chrome.bak to the it's original.

The issue was resolved as detailed in the chat comment section by renaming the home directory to a backup name, then creating a new home directory where Google Chrome worked. Then the backup directory was migrated to the new space.

  • At me it is all configured had already been. If click All cockies and site data cookies there, so it does not delete cookies when closing Google Chrome
    – Novah
    Sep 9 '16 at 13:05
  • @Novah The cookies isn't your issue. I put the steps referring to cookies because of your reference to it in the comments. You issue should be resolved by following the steps for passwords in the answer. Did those steps work? Sep 9 '16 at 13:10
  • no, it does not work.
    – Novah
    Sep 9 '16 at 13:13
  • @Novah In the password section, click Manage Passwords then checkmark Auto Sign-in. Also in the manage password section, scroll to the bottom and make sure Never Saved isn't set for the site you're having problems with. Sep 9 '16 at 13:19
  • Checkbox Auto Sign-in, and so checked
    – Novah
    Sep 9 '16 at 13:25


If above answer does not solve the issue, installing the beta version of Google Chrome can workaround the problem.

apt install google-chrome-beta  

This seems not to solve it (entry preserved for historical reasons):

I have the very same problem and did a few hours of debugging.

My problem is only related to google-chrome-stable Version 53.0.2785.101 (64-bit) on ubuntu 16.04.

When I login at a website, cookies are set correctly. When I close chrome, log out, log back in again, the cookies are still there and everything is fine. However, if I reboot, the cookies are gone and I need to login again.

I did some debugging (reinstalling chrome, reverting to default config, starting from a clean config, everything as suggested above, ...) and the bug persits.

I installed google-chrome-unstable Version 55.0.2853.0 dev (64-bit) and everything works fine (while stable still has the issue). So this is probably a chrome software bug.

My "solution": Use firefox/chrome-unstable for a few days/weeks, just wait for the update which fixes the issue to propagate to google-chrome-stable.

By the way, I'm using ubuntu 16.04 (systemd) with dm mapper/cryptsetup which was upgraded from 14.04 and I'm still not 100% sure that my crypt partition is unmounted every time 100% correctly (though the fs is always clean). @Novah, do you have a similar setup?

It is September 2016 when I write this advice. If it hasn't resolved within a month automatically, my answer is wrong ;-) I hope to spare you a lot of debugging and frustration.

  • Hey! Unfortunately didn't work for me :( . Still struggling with this issue. My steps were the following: removed the stable version, removed google-chrome from ~/.config, installed latest dev version which is 55.0.2853.0 dev (64-bit). Authentication is dropped even when I just close the browser window. And every time I open it back I get a message "your profile could not be opened correctly...". (Ubuntu 16.04)
    – Igor Bukin
    Sep 11 '16 at 19:10
  • @corny I have installed google-chrome-beta and the problem persists
    – Novah
    Sep 12 '16 at 12:49

Please note this is already reported to the Chromium Bug Tracker: https://bugs.chromium.org/p/chromium/issues/detail?id=631171


I had the same problem, but my system is ubuntu 14.04.

If your system also asked for keyring password every start google chrome (also restart system), i think that because Google chrome cannot get your saved google-password because your saved google-password locked by the keyring. You have to make sure that keyring is unlocked before you start Google chrome, not after. Here is my solution:

  1. Open google chrome.
  2. Login back to google account as usual and make sure there is no yellow warning icon before your username at top right corner. (just do it)
  3. Close google chrome.
  4. Open up Dash and open User Account, then turn "off" automatic login.
  5. Restart system.

By turning automatic login to "off", I thought this automatically will unlock keyring every login system, so Google chrome can get your google account password from keyring.

I know there are also another solution about disable keyring (by set keyring password to blank), but i think that is not secure.


I was facing same issues. In new install, I installed chrome as root ( not sudo). After restarting the program worked well. Learning this, I uninstalled chrome from the previous PC and installed it again as root user. Now everything is fine and the annoying login prompt is gone.

sudo -i
apt-get remove google-chrome*
apt-get autoremove
apt-get clean  
apt-get install google-chrome-stable  
  • Doing sudo apt-get package_name should also work. One should stay away from running commands from the root account directly as a miss-typed command can lead to very unpleasant results. Dec 30 '16 at 5:10
  • thanks karel. Running any program as root require special attention otherwise system could be broken Dec 30 '16 at 6:02
  • Its george not karel look at the end of the comment to see who made it ;). Dec 30 '16 at 6:08
  • 1
    I want to thank both of You . George and Karel Dec 30 '16 at 12:27

I have encountered the same problem. For the issue, it is because of the automatic ubuntu login.

So, for the easiest fix, just disable the automatic login.

Disable the automatic login for Ubuntu:

Ubuntu disable automatic login

Disable the automatic login for Ubuntu:

  • Open terminal

  • Enter, sudo nano /etc/lightdm/lightdm.conf

  • Comment your username,


  • Save and exit, reboot.

Another solution where you don't need to give Ubuntu access to your entire Google Account:

Go to Passwords & Keys, set a blank password for Default keyring. Restart your system.


Add on for 2-Factor-Authentication: I did everything in the selected solution and still after reboot, the login was paused.

More further on, I could not log in via the two factor authentication (but SMS worked, but it was annoying to log in each time again by this method), because chrome was not able to note my confirmation done in my smart phone.

And so I had to agree to @Vikas Avnish above. You could reinstall but a shorter solution WITHOUT loosing your tabs for example (and the login) is simply reset the application, which worked for me finally (after taking steps from the preferred solution above!!): Chrome Settings sequence to click

So here the steps in text form:

  1. Goto chrome settings
  2. Type in "reset settings" OR
  3. Choose "Reset
  4. Settings" on the left pane
  5. Click on "Restore settings to their original defaults"
  6. Click on the (blue) button "Reset Settings"

After that it finally worked for me again with the "2-Factor-Authentication"! Plus: I was not loosing any worthful working tabs that I arranged in my two windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.