I'm not sure what changed in my environment, but today I started noticing some behavior I don't like:

If I have a window maximized and I click the title of the window, the window unmaximize. I know this behavior wasn't there before because that is normally how I change from one window to another using my mouse and I just starting to notice this.

The question is: How can I prevent GNOME from unmaximizing my window when I single click the title bar on a maximized window?

1 Answer 1


After a few hours of waiting (I'm very impatient), I decided to do a research myself and I remembered that there was couple of extensions I upgraded in the past couple of days so went ahead and disabled one by one my extensions until I found the offender. Apparently the ShellTile extension recently upgraded and they introduced this very annoying feature, disabling the extension gets everything back to normal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .