0

I've installed Ubuntu 16.04 on my Lenovo Yoga 2 13 (not pro) and almost everything is working out of the box, however I'm experiencing a single issue that unfortunately is a deal-breaker for me: sometimes the computer does not wake up from suspend.

I tried to suspend by both closing the lid or by entering pm-suspend, however the result is the same. Most of the times it suspends and resume correctly, but sometimes (maybe once a day) when I open the lid the keyboard (which has backlight) lights up and the fan starts to spin (as normal when resuming) but the screen says completely black. I tried shortcuts to drop to console mode but with no success... the only thing I can do is to force shutdown by keeping power button pressed. The issue seems to be random, I'm not able to reproduce it (for instance it does not depend on the amount of time the computer has been sleeping or if power source is switched by plugging or unplugging AC while in suspend mode).

I've found various threads for other laptops or for different configurations of mine, but I was not able to solve the issue. Previously I tried with older versions such as 14.04, 15.04, 15.10 and even Fedora 22 and 23 but the issue persists, so it is not linked to a specific version. My Yoga 2 13 has i3 processor, 4GB of RAM, 256GB SSD, Intel 7260 WIFI and Intel HD 4000 graphics.

With Windows 10 this does not happen. Someone advises to turn off USB3 in BIOS but I found no such option for my model.

Does anyone have any suggestion? Thank you!

1

After a lot of investigation I think I got to the root of the problem. My computer came with a 500GB SSHD that I immediately replaced with a Crucial MX100 256GB SSD which seems to be among those that do not cope very well with Linux. In particular after suspend the SSD gets disconnected, so it is not possible to resume and I get the black screen. Fortunately it was not necessary to buy another one but it was enough to add these parameters to kernel options at boot:

libata.force=1:nohrst,1.00:noncq

nohrst prevents hard resets on SATA port (this is the option that solved the issue) and noncq disables native command queuing that caused some random lags while using the computer. The 1.00 value before colon is the identifier assigned by libata to my SSD (SATA port 1 device 00), for nohrst option only the port ID (1) must be specified.

I tried to suspend/resume a lot of times with no problems... I hope things will stay this way.

Finally I can enjoy Ubuntu on my Yoga 2 13 :-)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.