3

I have installed Ubuntu 16.04 but I am stuck because the distribution can not install the 32-bit libraries sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6.

My output is

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     lib32stdc++6 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.2) but 5.4.0-6ubuntu1~16.04.1 is to be installed
                    Depends: lib32gcc1 (>= 1:4.2) but it is not installable
                    Depends: libc6-i386 (>= 2.18) but it is not installable
    E: Unable to correct problems, you have held broken packages.

Is there a way to solve this issue or I should just revert to 15.04?

  • 2
    Please edit your question and add the outputs of dpkg --print-architecture, dpkg --print-foreign-architectures and apt policy lib32stdc++6 gcc-5-base lib32gcc1 libc6-i386. Also don't forget to run sudo apt update before trying to install packages. And no, 15.04 is no longer supported and you should not downgrade to this release. – Byte Commander Sep 7 '16 at 20:05
  • FYI, you do need those libraries, and your build will fail without them. – Android Dev Sep 7 '16 at 21:12
  • is a problem solved? – piotrek1543 Sep 20 '16 at 19:02
  • Only lib32stdc++6 was needed in my case and it got installed without any issues. Did you perform a clean install of 16.04 or upgrade from 15.10? – Prahlad Yeri Sep 29 '16 at 12:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.