0

When I press the volume keys (F2 for -, F3 for + and F1 for mute with no need to press Fn)
I've tried the instructions from here to run:

gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up
gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-down
gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-mute

but It didn't work for me.

Is there an alternate way to fix this?

3

Sorry for digging out an old post, but I have found a solution In my case it was an issue with actions assigned to

XF86AudioLowerVolume
XF86AudioRaiseVolume

in the file

~/.config/openbox/lubuntu-rc.xml

Try to find a command that will work for lowering/raising volume from the terminal, in my case it is

amixer -D pulse sset Master 5%-
amixer -D pulse sset Master 5%+

so my entries in the file look like this (I left the default lubuntu entries commented out)

<keybind key="XF86AudioRaiseVolume">
<action name="Execute">
<!-- <command>amixer -q sset Master 3%+ unmute</command> -->
<command>amixer -D pulse sset Master 5%+</command>
</action>
</keybind>
<keybind key="XF86AudioLowerVolume">
<action name="Execute">
<!--     <command>amixer -q sset Master 3%- unmute</command> -->
<command>amixer -D pulse sset Master 5%-</command>
</action>
</keybind>

This whole section is inside the element (as per https://wiki.lxde.org/en/LXDE:Questions#How_do_I_make_my_special_keyboard_buttons_.28mute.2C_volume.2C_screen_brightness_....29_work.3F )

You may need to logout/login or restart after making changes to the file.

Hope this helps.

  • Similarly, you could fix muting/unmuting by replacing amixer -q sset Master toggle with mixer -D pulse sset Master toggle – kaartic Dec 30 '18 at 13:08
0

In my case, I checked out the Sound settings and saw in the Output section that I had turned on the option 'Allow louder than 100%'. Turning it off resolved the problem for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.