0

I have an issue. I was Configuring Git using the following command for my ROR application. I added the ssh key and tried to check this using ssh -T git@github.com command it is throwing the following error.

Error:

The authenticity of host 'github.com (192.30.253.113)' can't be established.
RSA key fingerprint is 16:27:ac:a5:76:28:2d:36:63:1b:56:4d:eb:df:a6:48.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'github.com,192.30.253.113' (RSA) to the list of known hosts.
Permission denied (publickey).

I generated the ssh key using following command.

git config --global color.ui true
git config --global user.name "YOUR NAME"
git config --global user.email "YOUR@EMAIL.com"
ssh-keygen -t rsa -b 4096 -C "YOUR@EMAIL.com"

After that i added the key using this link(https://github.com/settings/ssh).But when i tried to test it using below command it is throwing this error.

ssh -T git@github.com

Please help me to resolve this issue. I am using ubuntu 14.04.

0

It asks for filename when you create the key, please don't give any file name then only you will not fail. Since the git clone tries to find the ida_rsa file which git can't find if you give some name at the time of creation of key. That worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.