1

I run a dual boot w/ Windows 7. Recently, I installed Windows 7 Service Pack 1 which, surprise surprise, screwed up Grub and left Windows the default OS w/ no option to boot into Ubuntu. This is usually a pretty easy fix (boot-repair), but the problem is I can't get a LiveCD that boots.

When I boot from a LiveCD usb, the screen flicks to TTY1, then to a black screen. The screen stays black unless I press ctrl + alt + F1 to get back to TTY1, where I'm then asked for a username and password. I've tried ubuntu with a blank password and this does not work.

I'm using this image. I've tried with a fresh USB multiple times. Anyone have any ideas?

  • To start solving the issue you probably need to post /var/log/Xorg.0.log… But, as the actual problem you need to solve is to just restore grub, you can do it from the tty perfectly fine, there's no need at configuring Internet, and alike. If you really need Live CD/USB, you could also try to boot from Fedora with Gnome, because… err… I struggle to say specifically, just a number of trivia tends to be more stable. – Hi-Angel Sep 6 '16 at 19:33
  • Ah, yeah, blank password didn't work. Well, in this case give a try to another LiveCD. At the very least, where password is working – Hi-Angel Sep 6 '16 at 19:40
0

Try using EasyUEFI in Windows to adjust the boot order -- move the ubuntu item to the top of the boot list. This should fix the problem; however, be aware that there are buggy EFIs that may forget boot entries or have problems with re-ordering them. There's also a slim chance that Windows has deleted the Ubuntu entry, in which case it will have to be re-created.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.