1

I tried upgrading my Ubuntu from 14.04 to 16.04 but after reboot several applications aren't working anymore. The problem is several dependancy errors.

Output sudo dpkg -a --configure:

    dpkg: dependency problems prevent configuration of ure:
 ure depends on libstdc++6 (>= 5.2); however:
  Version of libstdc++6:amd64 on system is 4.8.4-2ubuntu1~14.04.3.

dpkg: error processing package ure (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of duplicity:
 duplicity depends on python-lockfile (>> 1:0.9); however:
  Version of python-lockfile on system is 1:0.8-2ubuntu2.

dpkg: error processing package duplicity (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-uno:
 python3-uno depends on libreoffice-core (= 1:5.1.4-0ubuntu1); however:
  Package libreoffice-core is not installed.
 python3-uno depends on python3 (>= 3.5~); however:
  Version of python3 on system is 3.4.0-0ubuntu2.
 python3-uno depends on python3.5; however:
  Package python3.5 is not installed.
 python3-uno depends on libpython3.5 (>= 3.5.0~b1); however:
  Package libpython3.5 is not installed.
 python3-uno depends on libstdc++6 (>= 5); however:
  Version of libstdc++6:amd64 on system is 4.8.4-2ubuntu1~14.04.3.
 python3-uno depends on ure; however:
  Package ure is not configured yet.

dpkg: error processing package python3-uno (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpoppler58:amd64:
 libpoppler58:amd64 depends on libstdc++6 (>= 4.9); however:
  Version of libstdc++6:amd64 on system is 4.8.4-2ubuntu1~14.04.3.

dpkg: error processing package libpoppler58:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-dev:amd64:
 libc6-dev:amd64 depends on libc6 (= 2.23-0ubuntu3); however:
  Version of libc6:amd64 on system is 2.19-0ubuntu6.9.

dpkg: error processing package libc6-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome-desktop-3-dev:amd64:
 libgnome-desktop-3-dev:amd64 depends on libgnome-desktop-3-12 (= 3.18.1-1ubuntu1); however:
  Package libgnome-desktop-3-12 is not installed.
 libgnome-desktop-3-dev:amd64 depends on gir1.2-gnomedesktop-3.0 (= 3.18.1-1ubuntu1); however:
  Package gir1.2-gnomedesktop-3.0 is not installed.
 libgnome-desktop-3-dev:amd64 depends on libgtk-3-dev (>= 3.3.6); however:
  Package libgtk-3-dev is not installed.
 libgnome-desktop-3-dev:amd64 depends on gsettings-desktop-schemas-dev; however:
  Package gsettings-desktop-schemas-dev is not installed.
 libgnome-desktop-3-dev:amd64 depends on libxkbfile-dev; however:
  Package libxkbfile-dev is not installed.

dpkg: error processing package libgnome-desktop-3-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc-dev-bin:
 libc-dev-bin depends on libc6 (>> 2.23); however:
  Version of libc6:amd64 on system is 2.19-0ubuntu6.9.

dpkg: error processing package libc-dev-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of network-manager-pptp:
 network-manager-pptp depends on libnm0 (>= 1.1.90); however:
  Package libnm0 is not installed.
 network-manager-pptp depends on ppp (>= 2.4.7-1+~); however:
  Version of ppp on system is 2.4.5-5.1ubuntu2.2.

dpkg: error processing package network-manager-pptp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ppp:
 network-manager (1.2.0-0ubuntu0.16.04.3) breaks ppp (<< 2.4.6) and is unpacked but not configured.
  Version of ppp to be configured is 2.4.5-5.1ubuntu2.2.

dpkg: error processing package ppp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of uno-libs3:
 uno-libs3 depends on libstdc++6 (>= 5.2); however:
  Version of libstdc++6:amd64 on system is 4.8.4-2ubuntu1~14.04.3.

dpkg: error processing package uno-libs3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libicu55:amd64:
 libicu55:amd64 depends on libstdc++6 (>= 5.2); however:
  Version of libstdc++6:amd64 on system is 4.8.4-2ubuntu1~14.04.3.

dpkg: error processing package libicu55:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libglib2.0-bin:
 libglib2.0-bin depends on libglib2.0-0 (= 2.48.1-1~ubuntu16.04.1); however:
  Version of libglib2.0-0:amd64 on system is 2.40.2-0ubuntu1.

dpkg: error processing package libglib2.0-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of deja-dup:
 deja-dup depends on libgtk-3-0 (>= 3.16.2); however:
  Version of libgtk-3-0:amd64 on system is 3.10.8-0ubuntu1.6.
 deja-dup depends on adwaita-icon-theme; however:
  Package adwaita-icon-theme is not installed.

dpkg: error processing package deja-dup (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of network-manager:
 network-manager depends on libgnutls30 (>= 3.4.0); however:
  Package libgnutls30 is not installed.
 network-manager depends on libndp0 (>= 1.2); however:
  Package libndp0 is not installed.
 network-manager depends on libnm0 (>= 1.1.93); however:
  Package libnm0 is not installed.
 network-manager depends on init-system-helpers (>= 1.18~); however:
  Version of init-system-helpers on system is 1.14.
 network-manager depends on lsb-base (>= 4.1+Debian11ubuntu7); however:
  Version of lsb-base on system is 4.1+Debian11ubuntu6.
 network-manager depends on isc-dhcp-client (>= 4.3.1-5ubuntu1); however:
  Version of isc-dhcp-client on system is 4.2.4-7ubuntu12.4.

dpkg: error processing package network-manager (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of zlib1g-dev:amd64:
 zlib1g-dev:amd64 depends on libc6-dev | libc-dev; however:
  Package libc6-dev:amd64 is not configured yet.
  Package libc-dev is not installed.
  Package libc6-dev:amd64 which provides libc-dev is not configured yet.

dpkg: error processing package zlib1g-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of network-manager-pptp-gnome:
 network-manager-pptp-gnome depends on libnm-gtk0 (>= 1.0.6); however:
  Version of libnm-gtk0 on system is 0.9.8.8-0ubuntu4.4.
 network-manager-pptp-gnome depends on libnm0 (>= 1.1.90); however:
  Package libnm0 is not installed.
 network-manager-pptp-gnome depends on libnma0 (>= 1.1.90); however:
  Package libnma0 is not installed.
 network-manager-pptp-gnome depends on network-manager-pptp (= 1.1.93-1ubuntu1); however:
  Package network-manager-pptp is not configured yet.

dpkg: error processing package network-manager-pptp-gnome (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libedit2:amd64:
 libedit2:amd64 depends on libtinfo5 (>= 6); however:
  Version of libtinfo5:amd64 on system is 5.9+20140118-1ubuntu1.

dpkg: error processing package libedit2:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libedit2:i386:
 libedit2:i386 depends on libtinfo5 (>= 6); however:
  Version of libtinfo5:i386 on system is 5.9+20140118-1ubuntu1.

dpkg: error processing package libedit2:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of network-manager-gnome:
 network-manager-gnome depends on libnm0 (>= 1.1.90); however:
  Package libnm0 is not installed.
 network-manager-gnome depends on libnma0 (= 1.2.0-0ubuntu0.16.04.3); however:
  Package libnma0 is not installed.
 network-manager-gnome depends on network-manager (>= 1.1); however:
  Package network-manager is not configured yet.
 network-manager-gnome depends on adwaita-icon-theme; however:
  Package adwaita-icon-theme is not installed.

dpkg: error processing package network-manager-gnome (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus-sendto:
 nautilus-sendto depends on nautilus (>= 1:2.91); however:
  Package nautilus is not configured yet.

dpkg: error processing package nautilus-sendto (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 ure
 duplicity
 python3-uno
 libpoppler58:amd64
 libc6-dev:amd64
 libgnome-desktop-3-dev:amd64
 libc-dev-bin
 network-manager-pptp
 ppp
 uno-libs3
 libicu55:amd64
 libglib2.0-bin
 deja-dup
 network-manager
 zlib1g-dev:amd64
 network-manager-pptp-gnome
 libedit2:amd64
 libedit2:i386
 network-manager-gnome
 nautilus-sendto

I already tried lots of things, like:

  • changing sources.list
  • running following commands:

    sudo apt-get clean

    sudo apt-get update
    
    sudo apt-get install -f
    
    sudo dpkg -a --configure
    
    sudo apt-get dist-upgrade
    

Output sudo apt-get install -f

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 deja-dup : Depends: libgtk-3-0 (>= 3.16.2) but 3.10.8-0ubuntu1.6 is installed
            Depends: adwaita-icon-theme but it is not installable
 duplicity : Depends: python-lockfile (> 1:0.9) but 1:0.8-2ubuntu2 is installed
 libc-dev-bin : Depends: libc6 (> 2.23) but 2.19-0ubuntu6.9 is installed
 libc6-dev : Depends: libc6 (= 2.23-0ubuntu3) but 2.19-0ubuntu6.9 is installed
 libedit2 : Depends: libtinfo5 (>= 6) but 5.9+20140118-1ubuntu1 is installed
 libedit2:i386 : Depends: libtinfo5:i386 (>= 6) but 5.9+20140118-1ubuntu1 is installed
 libglib2.0-bin : Depends: libglib2.0-0 (= 2.48.1-1~ubuntu16.04.1) but 2.40.2-0ubuntu1 is installed
 libgnome-desktop-3-dev : Depends: libgnome-desktop-3-12 (= 3.18.1-1ubuntu1) but it is not installable
                          Depends: gir1.2-gnomedesktop-3.0 (= 3.18.1-1ubuntu1) but it is not installed
                          Depends: libgtk-3-dev (>= 3.3.6) but it is not installed
                          Depends: gsettings-desktop-schemas-dev but it is not installed
                          Depends: libxkbfile-dev but it is not installed
 libicu55 : Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
 libpoppler58 : Depends: libstdc++6 (>= 4.9) but 4.8.4-2ubuntu1~14.04.3 is installed
 nautilus : Depends: libgnome-desktop-3-12 (>= 3.18.1) but it is not installable
            Depends: libgtk-3-0 (>= 3.16.2) but 3.10.8-0ubuntu1.6 is installed
            Depends: libtracker-sparql-1.0-0 (>= 0.10.0) but it is not installable
            Depends: nautilus-data (>= 1:3.18) but 1:3.10.1-0ubuntu9.11 is installed
 network-manager : Depends: libgnutls30 (>= 3.4.0) but it is not installable
                   Depends: libndp0 (>= 1.2) but it is not installed
                   Depends: libnm0 (>= 1.1.93) but it is not installable
                   Depends: init-system-helpers (>= 1.18~) but 1.14 is installed
                   Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.1+Debian11ubuntu6 is installed
                   Depends: isc-dhcp-client (>= 4.3.1-5ubuntu1) but 4.2.4-7ubuntu12.4 is installed
                   Recommends: ppp (>= 2.4.6) but 2.4.5-5.1ubuntu2.2 is installed
                   Recommends: modemmanager
                   Breaks: ppp (< 2.4.6) but 2.4.5-5.1ubuntu2.2 is installed
 network-manager-gnome : Depends: libnm0 (>= 1.1.90) but it is not installable
                         Depends: libnma0 (= 1.2.0-0ubuntu0.16.04.3) but it is not installable
                         Depends: adwaita-icon-theme but it is not installable
 network-manager-pptp : Depends: libnm0 (>= 1.1.90) but it is not installable
                        Depends: ppp (>= 2.4.7-1+~) but 2.4.5-5.1ubuntu2.2 is installed
 network-manager-pptp-gnome : Depends: libnm-gtk0 (>= 1.0.6) but 0.9.8.8-0ubuntu4.4 is installed
                              Depends: libnm0 (>= 1.1.90) but it is not installable
                              Depends: libnma0 (>= 1.1.90) but it is not installable
 python3-uno : Depends: libreoffice-core (= 1:5.1.4-0ubuntu1) but it is not installed
               Depends: python3 (>= 3.5~) but 3.4.0-0ubuntu2 is installed
               Depends: python3.5 but it is not installable
               Depends: libpython3.5 (>= 3.5.0~b1) but it is not installable
               Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is installed
 uno-libs3 : Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
 ure : Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

Anyone have an idea how I can fix these dependencies? The biggest problem is that I can not open nautilus and network manager. So wireless is no option, got my ethernet working by adding eth0 in /etc/network/interfaces

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.