I recently bought this wireless webcam. I'm having trouble getting it to work on Ubuntu 11.04.

I ran lsusb and got the folowing information about the device

Bus 006 Device 003: ID 0416:a91a Winbond Electronics Corp.

I did a Google serach for teh device ID and this website informs me that it matches the LogiLink Wireless Webcam (so Maplin probably just rebranded this!). What this website states is that this device should work, which it doesn't.

The problem I'm facing is that I don't get any actual video being streamed or shown. The built in microphone works and, when running Cheese, when I press the camera button on the webcam itself the software recognises that the button is pressed.

On that note, when running cheese from the terminal with this webcam attached I get the following error

libv4l2: error getting pixformat: Invalid argument
libv4l2: error setting pixformat: Input/output error

Any help is appreciated


I am fighting with a similar problem right now.

According to the thread on this website, your device must be recognized as a video device by the kernel. Maybe it isn't, although it should.



to get a list of devices currently plugged in via USB.

Then run

lsusb -d YOUR:DEVICEID -v | grep -i "Video"

Quoting from the thread

after you connected some usb device to the host it will be checked by usb-core driver every device has some class description. if your device say, it belong to: 14 - video class, uvcvideo will initiate it. if the device is not video class device, then there is no way to uvcvideo will know about it. (except you will force it, but there is no guaranty)

"Forcing it" requires more work, supposedly. Can't say more right now, sorry.

| improve this answer | |

I had the same error message on Fedora 16, with my SiGma Micro webcam (1c4f:3002). Bizarrely, the camera was working in Skype but nothing else!

For me, the following steps fixed the problem:

$ sudo -s
# echo "options uvcvideo quirks=2" >> /etc/modprobe.d/uvcvideo.conf
# rmmod uvcvideo
# modprobe uvcvideo

You could also reboot instead of the rmmod / modprobe sequence.

I found the solution in a thread on the linux-media mailing list, from 2009.

Hope this helps!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.