4

When I have updated my computer to Ubuntu 16.04, xpra package has updated to v0.15.8.

I have some compatibility problems with this version. I have read that v0.15.x is an unsupported version and v0.14.x is the current LTS (long term support) release (https://www.xpra.org/trac/wiki/Versions).

How can I install xpra V0.14.x on ubuntu 16.04?

6

Updating to 0.14.x still did not allow me to launch xpra but updating to the latest branch 2.0.x did.

TL;DR copied from my blog:

# Administrator privileges
sudo su -

# Import the packager's key:
apt-get install curl
curl http://winswitch.org/gpg.asc | apt-key add -

# Xenial Xerus (16.04)
echo "deb http://winswitch.org/ xenial main" > /etc/apt/sources.list.d/winswitch.list;
apt-get install software-properties-common >& /dev/null;
add-apt-repository universe >& /dev/null;
apt-get update;
apt-get install winswitch
1
  • Sorry I did not know. Done :) – brtknr Mar 22 '17 at 13:55
0

Open the terminal and type:

cd Desktop/
wget -c http://xpra.org/dists/xenial/main/binary-amd64/xpra_0.14.35-1_amd64.deb # official deb package from xpra.org
sudo dpkg -i xpra_0.14.35-1_amd64.deb  

xpra v0.14.x is the current LTS (long term support) release, and xpra_0.14.35-1_amd64.deb is compatible with Ubuntu 16.04.

If you get a broken packages message when updating software, then remove xpra using this command:

sudo dpkg -r xpra  

If you still get a broken packages message when updating software, then it wasn't xpra's fault. You need to solve the broken packages error message first before you install xpra. This should be asked as a separate question however.

1
  • Thanks but now Synaptic Package Managers tells me that I have an error (broken package) and I can not install software updates. – Mikel Antoñana Sep 29 '16 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.