0

on an Ubuntu (16.04 LTS) working as Webserver I have installed overlayfs (I did already some months ago on another machine). On both machine I have:

overlayroot="tmpfs:swap=1,recurse=0"

But on the new one, boot fails with

overlayfs: missing working dir

How do I set the working dir parameter?

Thanks

0

Hopelessly late I know, but just in case someone else should wonder - workdir should be set for you by /usr/share/initramfs-tools/scripts/init-bottom/overlayroot. Maybe you need to regenerate your initramfs?

The default is /media/root-rw/overlay-workdir/_ and you can set it manually by adding workdir=... as an option to the overlayfs mount command/fstab entry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.