0

I want to try to install Ubuntu 16.04 on a new laptop. This laptop has 64 GB eMMC storage which has pre-installed Windows 10. I don't want to change anything or break Windows installation. Because I don't own this laptop, I only borrow it for several days. I want to return it to the owner as original as I took it from him. But I want to install and test if this laptop compatible with linux or not.

So I put a 16 GB micro sd card to card slot of laptop, plug Ubuntu 16.04 installation USB pen-drive to USB slot and installed it. I followed these steps:

64 GB eMMC storage seen as emmcblk0 and it has 4 GPT partitions One of them is EFI partition.

16 GB sd card seen as emmcblk1 and I formatted it as one ext4 partition and emmcblk1p1 used for root partition during installation steps. I did not create any other EFI or swap partitions.

I choose to install bootloader to emmcblk1 (I tried with another installation to emmcblk1p1 and I get same result). I did not choose to install to emmcblk0 because I don't want to change anything 64 GB eMMC Windows disk.

When I try to boot system, I get 2 EFI entries called "ubuntu", and If I try to boot from one of them system drops to GRUB2 shell prompt. When I run ls command, I can only see (hd0,gpt1) (hd0,gpt2) (hd0,gpt3) (hd0,gpt4) entries. These are 64 GB eMMC drive's GPT partitions and I don't see emmcblk1 from GRUB2 shell.

What should I do from this point? What's wrong with this installation steps?

Thanks

1

You poosibly made changes to your friends system already. Please create a bootinfo-summary following the steps in this link: https://help.ubuntu.com/community/Boot-Info If you use boot-repair don't click the "recommended repair"-button, this would possibly make more changes to the system. Post the given URL so we can see what happend to your friends system and are able to give advice.

  • Thank you for your reply. Here is the link for report: paste2.org/3PPbx30w On the other hand, I didn't mentioned, I already tried to fix with boot repair 2 times and these are their reports: paste2.org/CDDFX95g paste2.org/I9UJn57n Thanks and best regards – coolman Sep 5 '16 at 15:41
  • Your action added a few file to the ESP (EFI System Partition).The ESP is mmcblk0p1. The files are in a single folder with the name "/ubuntu". – mook765 Sep 5 '16 at 17:33
  • Ok. If I delete ubuntu folder under mmcblk0p1/EFI/ubuntu my friend's computer will be as original. But how can I install and boot ubuntu to mmcblk1? grub2 can't see mmcblk1. – coolman Sep 5 '16 at 17:44
  • Shutdown, remove your micro sd card and pendrive, boot directly to mmcblk0 and see what happens. If the machine boots directly to Windows you shouldn't delete this files. – mook765 Sep 5 '16 at 17:59
  • 1
    Read this link. It is not as easy to make bootable installtion and needs changes to your friends system. Use option "Try without installing" would be better solution for a few days... – mook765 Sep 5 '16 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.