3

I added indicators=keyboard to /etc/lightdm/lightdm-gtk-greeter.conf and a keyboard chooser appears, but I cannot for the life of me get it to list multiple keyboard layouts. I am on Lubuntu 14.04. Have tried using unity-control-center to add a layout. Adding a layout to my ibus. Tried forcing the gsettings on the lightdm user (they seem to get regenerated / overwritten on reboot). I did this to my /etc/default/keyboard:

XKBMODEL="pc105,pc105"
XKBLAYOUT="us,us"
XKBVARIANT="dvorak,"

If I invert the order of those pairs then I get QWERTY only option in lightdm, and if I have them like this I get the Dvorak only option in the drop-down, but I still cannot find a way to make it list both of them.

I have multiple users on this computer that each prefer to type passwords with a different layout, so I really need this feature.

Does anyone know how to do this?

0

You can make lightdm-gtk-greeter show a keyboard layout menu in the top right panel. One way to do it is to create a file in the /etc/lightdm/lightdm-gtk-greeter.conf.d folder and list a custom selection of indicators to be shown:

$ cat /etc/lightdm/lightdm-gtk-greeter.conf.d/50-modify-indicators.conf
[greeter]
indicators = ~host;~spacer;~session;~language;~layout;~a11y;~clock;~power

(The ~layout option represents the keyboard layout menu.)

One disadvantage is that the menu lists all available (i.e. quite a few) keyboard layouts, so even if you can switch keyboard layout that way, it's not very convenient.

  • @Anwar: To be honest I'm not quite happy with the solution; there ought to be something better. – Gunnar Hjalmarsson Sep 5 '16 at 13:47
  • If you read my question you'll note I have the keyboard indicator added already. I want to know how to get this indicator to list multiple layouts. – singpolyma Sep 5 '16 at 16:28
  • @singpolyma: You wrote that you added indicators=keyboard which does not sound right to me. So maybe you should try the above? – Gunnar Hjalmarsson Sep 5 '16 at 16:36
  • using ~layout instead shows nothing. I'm on 14.04 -- using keyboard works, but only shows a single layout (the default xkb option) – singpolyma Sep 6 '16 at 0:19
  • @singpolyma: Tested my answer on 14.04 and can confirm that ~layout doesn't work there for me either. Then I tested with keyboard, which works for me on both 14.04 and 16.04; actually it works better, because the list of options consists of actually added layouts, not all the available ones. I have only tested on Ubuntu, though, not Lubuntu. Guess I should edit my answer, but haven't time to do it right now. – Gunnar Hjalmarsson Sep 6 '16 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.