After installing Ubuntu Gnome 16.04.1 I started to notice the error message:

DMAR: Failed to map dmar0 al boot 

It was some time that I noticed some slowdowns in the POST process, especially during the detection of my USB webcam

After some research online, I found the detailed analysis (made for a Fedora OS)

Why is my syslog telling me that my bios is broken?

and I found out this message in my dmesg event log:

Your BIOS is broken; DMAR reported at address fed90000 returns all ones!

that appears only if the Intel VT(d) option is enabled in the BIOS.

As far as I understood from the a.m. post, unless there will be a new bios update, the situation cannot be solved. Unfortunately the latest bios is already installed and I seriously doubt new updates will come (my ASUS mobo is 3 or 4 years old now).

Now, since I sometimes use Virtualbox, I'd prefer to keep the intel VT(d) option enabled but I would like to avoid any mis-behavior of the USB peripherals (which happened in the past and now I'm inclined to explain with this bios-related issue)

I already tried to add the iommu=soft option at the kernel boot-up but it did not work.

Do you have any suggestions to solve or workaround this issue?

Is there any chance that a previous bios will work? I already tested the last two...

  • Desktop or laptop? 32 or 64-bit OS? How much memory (RAM) installed, in what configuration (ie: 4x2G)? Please paste your /etc/fstab for me to look at. Cheers, Al – heynnema Sep 4 '16 at 23:33
  • Hi heynnema! Thanks for repying. 64 bit OS on Desktop PC, 4x2GB RAM. Here is my fstab: pastebin.com/kDrmbm6j – Shock99er Sep 5 '16 at 19:13
  • How many slots available for RAM 4? More? Are they color-coded... probably 2 black and 2 white (if you have 4 slots). Cheers, Al – heynnema Sep 5 '16 at 20:21
  • 4 slots: color is black, blue, black, blue. Installed RAM in couples of some types as far as I remember: some type on same colour. Details here: pastebin.com/uXgnGM87 (although they are reported as 4 different Manufacturers!). – Shock99er Sep 6 '16 at 5:35
  • I'll post my new comment as a new answer so that I can format the output and add a lot of detail... – heynnema Sep 6 '16 at 12:42

Disable bios Intel virtualization technology. I was having the same problem.
I tried:

  • Using only one stick of ram;
  • Externally flashing bios using usb bios flash tool;
  • Putting hdd in ide and ahci mode in bios.

Always the same problem until I disable Intel virtualization technology.


Just to eliminate a possible hardware issue, we're going to play with your RAM. This will help us determine if you really have a BIOS problem or not.

First unplug your computer from the AC. Then push in and hold the main power button for 10 seconds. This will discharge any leftover power in the computer power supply.

Preferably, whist working inside of your computer, you shouldn't be on carpeting, and you should be close enough to something that you can ground yourself to... like a water pipe... bare metal. If that isn't possible where the computer is, then move it. Like near a heater, or near the kitchen counter sink. This is so we can discharge any static electricity from your body, before touching anything inside the computer.

Open the computer case. Touch a nearby ground. Carefully remove your 4 sticks of RAM by carefully depressing the latches on either end of each stick. Note which direction the sticks are facing. Handle the sticks of RAM by the edges only. Place the sticks on something non-static like a piece of foil. Now look at the sticks carefully to determine that they're all of the same type, have the same number of large chips, and have similar tags on them. For now, I'm going to assume that they're all the same. Let me know what you find here.

Touch a nearby ground again. Now we're going to reinsert only 2 of the RAM sticks (using similar sticks), making sure that each stick is properly inserted and clicked into their latches, and retry the computer looking for the errors. Then later, depending on the results, we'll re-add the remaining pair of sticks.

It's important how/where we reinsert the memory sticks. Look at my diagram below.

black - dimm 0 - first stick

blue - dimm 1 - empty

black - dimm 2 - second stick

blue - dimm 3 - empty

We want to use the same color pairs that includes dimm0. The other dimm number will depend if they numbered them 0,1,2,3 or 0,2,1,3.

Now use the computer, with only 2 sticks of RAM, and look for your error. Report back after this stage.

Cheers, Al

  • Hi Al, thanks for your detailed reply. All the RAM modules are of the same type (Kingston KVR1333D3N9/2G). Tried to install only 2 sticks (I had to put them on the blue slots as per my mobo ASUS P7P55 LX specifications). Unfortunately the error message is still there, even trying the other couple of ram modules... Should you have any further test to do, please let me know. Cheers Shock99er – Shock99er Sep 6 '16 at 20:09
  • When you put the 2nd pair in, did you remove the 1st pair from the blue sockets, and then place the 2nd pair in the exact same sockets? Or did you do something else? Cheers, Al – heynnema Sep 6 '16 at 20:43
  • I replaced the 2 modules with the remaining RAM sticks, installing them on the same slots. Thanks Shock99er – Shock99er Sep 6 '16 at 21:18
  • Well, I guess you've got a BIOS problem. Thanks for trying. Cheers, Al – heynnema Sep 6 '16 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.