2

This is after doing apt-get update; apt-get dist-upgrade within 14.04.

The upgrade to 16.04 (do-release-upgrade) left the following errors:

# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 default-jre : Depends: default-jre-headless (= 2:1.8-56ubuntu2) but 2:1.7-51 is installed
               Depends: openjdk-8-jre but it is not installed
 default-jre-headless : Depends: openjdk-7-jre-headless (>= 7~u3-2.1.1) but it is not installable
 icedtea-6-jre-jamvm : Depends: openjdk-6-jre-headless (= 6b39-1.13.11-0ubuntu0.14.04.1) but it is not installable
 icedtea-netx : Depends: openjdk-8-jre but it is not installed
                Depends: icedtea-netx-common (>= 1.6.2-3ubuntu1) but 1.5.3-0ubuntu0.14.04.1 is installed
 libc-dev-bin : Depends: libc6 (> 2.23) but 2.19-0ubuntu6.9 is installed
 libc6-dev : Depends: libc6 (= 2.23-0ubuntu3) but 2.19-0ubuntu6.9 is installed
 libfontconfig1-dev : Depends: libfontconfig1 (= 2.11.94-0ubuntu1.1) but 2.11.0-0ubuntu4.2 is installed
 libglib2.0-0-refdbg : Depends: libglib2.0-0 (= 2.48.1-1~ubuntu16.04.1) but 2.40.2-0ubuntu1 is installed
 libglib2.0-bin : Depends: libglib2.0-0 (= 2.48.1-1~ubuntu16.04.1) but 2.40.2-0ubuntu1 is installed
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.48.1-1~ubuntu16.04.1) but 2.40.2-0ubuntu1 is installed
 libgmpxx4ldbl : Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
 libreoffice : Depends: libreoffice-java-common (>= 1:5.1.4~) but 1:4.2.8-0ubuntu4 is installed
 libreoffice-base : Depends: libreoffice-base-drivers (= 1:5.1.4-0ubuntu1) but 1:4.2.8-0ubuntu4 is installed
                    Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is installed
                    Recommends: libreoffice-java-common (>= 1:5.1.4~) but 1:4.2.8-0ubuntu4 is installed
 libreoffice-base-core : Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is installed
 libreoffice-calc : Depends: libc6 (>= 2.23) but 2.19-0ubuntu6.9 is installed
                    Depends: libetonyek-0.1-1 but it is not installed
                    Depends: libicu55 (>= 55.1-1~) but it is not installed
                    Depends: libmwaw-0.3-3 but it is not installed
                    Depends: libodfgen-0.1-1 but it is not installed
                    Depends: liborcus-0.10-0v5 (>= 0.9.2-4ubuntu2) but it is not installed
                    Depends: librevenge-0.0-0 but it is not installed
                    Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
                    Depends: libwps-0.4-4 but it is not installed
 libreoffice-core : Depends: libclucene-contribs1v5 (>= 2.3.3.4) but it is not installed
                    Depends: libclucene-core1v5 (>= 2.3.3.4) but it is not installed
                    Depends: libcmis-0.5-5v5 but it is not installed
                    Depends: libeot0 but it is not installed
                    Depends: libfontconfig1 (>= 2.11.94) but 2.11.0-0ubuntu4.2 is installed
                    Depends: libglew1.13 (>= 1.12.0) but it is not installed
                    Depends: libhunspell-1.3-0 (>= 1.3.3) but 1.3.2-6ubuntu2.1 is installed
                    Depends: libicu55 (>= 55.1-1~) but it is not installed
                    Depends: librevenge-0.0-0 but it is not installed
                    Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
 libreoffice-draw : Depends: libcdr-0.1-1 but it is not installed
                    Depends: libdbus-1-3 (>= 1.9.14) but 1.6.18-0ubuntu4.3 is installed
                    Depends: libfreehand-0.1-1 but it is not installed
                    Depends: libmspub-0.1-1 but it is not installed
                    Depends: libmwaw-0.3-3 but it is not installed
                    Depends: libodfgen-0.1-1 but it is not installed
                    Depends: libpagemaker-0.0-0 (>= 0.0) but it is not installed
                    Depends: librevenge-0.0-0 but it is not installed
                    Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
                    Depends: libvisio-0.1-1 but it is not installed
                    Depends: libwpg-0.3-3 but it is not installed
 libreoffice-gnome : Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is installed
 libreoffice-gtk : Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is installed
 libreoffice-impress : Depends: libetonyek-0.1-1 but it is not installed
                       Depends: libmwaw-0.3-3 but it is not installed
                       Depends: libodfgen-0.1-1 but it is not installed
                       Depends: librevenge-0.0-0 but it is not installed
                       Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is installed
 libreoffice-math : Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is installed
 libreoffice-pdfimport : Depends: libpoppler58 (>= 0.41.0) but it is not installed
                         Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
 libreoffice-writer : Depends: libabw-0.1-1v5 but it is not installed
                      Depends: libe-book-0.1-1 but it is not installed
                      Depends: libetonyek-0.1-1 but it is not installed
                      Depends: libicu55 (>= 55.1-1~) but it is not installed
                      Depends: libmwaw-0.3-3 but it is not installed
                      Depends: libodfgen-0.1-1 but it is not installed
                      Depends: librevenge-0.0-0 but it is not installed
                      Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
                      Depends: libwpd-0.10-10 but it is not installed
                      Depends: libwpg-0.3-3 but it is not installed
                      Depends: libwps-0.4-4 but it is not installed
 libtk8.6 : Depends: libfontconfig1 (>= 2.11.1) but 2.11.0-0ubuntu4.2 is installed
 nautilus : Depends: libgnome-desktop-3-12 (>= 3.18.1) but it is not installed
            Depends: libgtk-3-0 (>= 3.16.2) but 3.10.8-0ubuntu1.6 is installed
            Depends: libtracker-sparql-1.0-0 (>= 0.10.0) but it is not installed
            Depends: nautilus-data (>= 1:3.18) but 1:3.10.1-0ubuntu9.11 is installed
 network-manager : Depends: libgnutls30 (>= 3.4.0) but it is not installed
                   Depends: libndp0 (>= 1.2) but it is not installed
                   Depends: libnm0 (>= 1.1.93) but it is not installed
                   Depends: init-system-helpers (>= 1.18~) but 1.14 is installed
                   Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.1+Debian11ubuntu6.1 is installed
                   Depends: isc-dhcp-client (>= 4.3.1-5ubuntu1) but 4.2.4-7ubuntu12.5 is installed
                   Recommends: ppp (>= 2.4.6) but 2.4.5-5.1ubuntu2.2 is installed
                   Recommends: modemmanager
                   Breaks: ppp (= 1.1.90) but it is not installed
                         Depends: libnma0 (= 1.2.0-0ubuntu0.16.04.3) but it is not installed
                         Depends: adwaita-icon-theme but it is not installed
 network-manager-pptp : Depends: libnm0 (>= 1.1.90) but it is not installed
                        Depends: ppp (>= 2.4.7-1+~) but 2.4.5-5.1ubuntu2.2 is installed
 network-manager-pptp-gnome : Depends: libnm-gtk0 (>= 1.0.6) but 0.9.8.8-0ubuntu4.4 is installed
                              Depends: libnm0 (>= 1.1.90) but it is not installed
                              Depends: libnma0 (>= 1.1.90) but it is not installed
 openjdk-6-jre : Depends: openjdk-6-jre-headless (= 6b39-1.13.11-0ubuntu0.14.04.1) but it is not installable
 python3-uno : Depends: python3 (>= 3.5~) but 3.4.0-0ubuntu2 is installed
               Depends: python3.5 but it is not installed
               Depends: libpython3.5 (>= 3.5.0~b1) but it is not installed
               Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is installed
 uno-libs3 : Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
 ure : Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

Note most are because of

Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed

What steps can correct that?

The majority, around libreoffice, might be curable by removing and then reinstalling libreoffice -- except apt-get doesn't allow even removing a package, out of an abundance of caution (and not trusting the user). Is there a "force" option to apt-get or dpkg to accomplish there?

(I've seen advice on similar questions here to just forget it and do a fresh installation of everything. Please don't bother to answer if that's your suggestion.)

Update:

Cleared out libreoffice using dpkg --remove for each of it's parts. Also, several other things. So now I'm down to:

# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 default-jre : Depends: default-jre-headless (= 2:1.8-56ubuntu2) but 2:1.7-51 is installed
               Depends: openjdk-8-jre but it is not installed
 default-jre-headless : Depends: openjdk-7-jre-headless (>= 7~u3-2.1.1) but it is not installable
 libc-dev-bin : Depends: libc6 (> 2.23) but 2.19-0ubuntu6.9 is installed
 libc6-dev : Depends: libc6 (= 2.23-0ubuntu3) but 2.19-0ubuntu6.9 is installed
 libfontconfig1-dev : Depends: libfontconfig1 (= 2.11.94-0ubuntu1.1) but 2.11.0-0ubuntu4.2 is installed
 libglib2.0-0-refdbg : Depends: libglib2.0-0 (= 2.48.1-1~ubuntu16.04.1) but 2.40.2-0ubuntu1 is installed
 libglib2.0-bin : Depends: libglib2.0-0 (= 2.48.1-1~ubuntu16.04.1) but 2.40.2-0ubuntu1 is installed
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.48.1-1~ubuntu16.04.1) but 2.40.2-0ubuntu1 is installed
 libgmpxx4ldbl : Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
 libtk8.6 : Depends: libfontconfig1 (>= 2.11.1) but 2.11.0-0ubuntu4.2 is installed
 network-manager : Depends: libgnutls30 (>= 3.4.0) but it is not installed
                   Depends: libndp0 (>= 1.2) but it is not installed
                   Depends: libnm0 (>= 1.1.93) but it is not installed
                   Depends: init-system-helpers (>= 1.18~) but 1.14 is installed
                   Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.1+Debian11ubuntu6.1 is installed
                   Depends: isc-dhcp-client (>= 4.3.1-5ubuntu1) but 4.2.4-7ubuntu12.5 is installed
                   Recommends: ppp (>= 2.4.6) but 2.4.5-5.1ubuntu2.2 is installed
                   Recommends: modemmanager
                   Recommends: network-manager-pptp but it is not installed
                   Breaks: ppp (= 1.1.90) but it is not installed
                         Depends: libnma0 (= 1.2.0-0ubuntu0.16.04.3) but it is not installed
                         Depends: adwaita-icon-theme but it is not installed
 openjdk-6-jre : Depends: openjdk-6-jre-headless (= 6b39-1.13.11-0ubuntu0.14.04.1) but it is not installable
                 Recommends: icedtea-netx but it is not installed
 uno-libs3 : Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
 ure : Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I'm thinking it might be safe for me to also toss network-manager, as this is a desktop system with each NIC fully configured locally (not DHCP). Tried to toss the JRE stuff, but that's got a web of dependencies to it.

Update 2:

By going through dependencies shown in apt-get -f install and installing packages individually by downloading them from Canonical and then using dpkg -i to install them, I was able to get to where I could see that the base problem was an old kdepim file that had dependencies no longer met. Removing kdepim then enabled apt-get -f install to do real work. But the end result was still a system with problems -- cgroup functionality wasn't there, xfce4 desktops were confused, a symlink of joe as jstar would segfault (although joe invoked as itself ran fine). So had to do a full new install anyway. Maybe this is what happens when it's been too many generations of Ubuntu on the same box via upgrades.

Never did use kdepim. Just something left over from when I used to use KDE as the desktop. Been xfce4 for years.

  • Try to install libstdc++6 manually by typing sudo apt-get update and sudo apt-get install libstdc++6 and see what you get – Bilal Sep 4 '16 at 23:01
  • When a system is insisting on apt-get -f install but can't complete that, there's no way to apt-get install anything. You can get the appropriate deb packages from Canonical and do dpkg -i for them, which I ended up doing. Still wasn't a good fix in the end. It is something I've used to unjam systems with simpler apt-get failures successfully. – user291949 Sep 6 '16 at 3:08
  • When apt-get is in the place of insisting on apt-get -f install it won't let you install anything until what it sees as broken is fixed -- not even an element that it reports as broken. This is an example of tools which have so many safety features added as to be of only limited use when the work to be done is inherently dangerous -- even when the failure to fix things is the greater danger than leaving them in their current state. – user291949 Sep 6 '16 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.