1

I have a clean install of ubuntu 16.04.1. I would like to disable compositing completely. I need to run ABAQUS, and the graphics window becomes transparent if compositing is enabled. Previously I used to run Kubuntu, and if compositing is disabled then ABAQUS GUI will not be transparent.

In 16.04 the ubuntu-2d is not there anymore! I have installed ccsm and tried to disable compositing in the "compiz" section, but that also removed all window decorations.

My goal is to run ABAQUS GUI (not particularly the unity-2D). "abaqus cae -mesa" did not help BTW. Any help is highly appreciated.

Thanks, Kodanda

  • I'm assuming you want the Unity DE? – anonymous2 Sep 5 '16 at 1:55
  • Yes, I am using Unity. I do not want to install another DE, unless there is no other option! – kodanda Sep 5 '16 at 14:38
  • bump! Any help! – kodanda Sep 6 '16 at 11:38
  • Perhaps using lxde is an option for me. After all it is not going to install tonnes of new libraries. I needed to install ĺxsession in addition to lxde to get the session changing option available in lightdm screen. – kodanda Sep 6 '16 at 22:19
1

No need to turn off compositing - on my Ubuntu 16.04.5 I just need to start ABAQUS with setting XLIB_SKIP_ARGB_VISUALS=1 like

$ XLIB_SKIP_ARGB_VISUALS=1 /opt/abaqus/Commands/abaqus cae -mesa -noStartupDialog;
0

Apparently unity-2D is discontinued in ubuntu 16.04. Thus lxde is the next slim option to have a session without compositing enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.