1

I have 5 nodes in my MAAS cluster. When I start them I want them to have a certain DNS server IP address. Instead there IP give from the internet facing side of the MAAS server.

Question: How do I change the DNS IP address which will be used by the MAAS nodes?

P.S.

ubuntu--> 14.04.5 MAAS--> 1.9.4

2

The simplest way to configure this in MAAS is to:

  • Set up DNS fowarders in the MAAS settings page
  • Enable MAAS to manage DNS for the cluster (in 1.x) or managed VLAN (in 2.x)

When MAAS deploys a node it will configure its resolver accordingly; in the case where the above settings are made and you are deploying Linux:

  • The servers' resolv.conf file will have the IP address for the MAAS Region controller
  • The BIND installation on the MAAS Region controller will have a forwarders entry set up for the addresses you provide.

The effect is that queries on the node will be sent to MAAS, which will resolve directly for queries in domains which it manages (by default, *.maas), and forward requests for everything else to the forwarder.

Note that we assume the forwarder correctly implements DNSSEC, which is sadly often not the case. For instance, see this question: Ubuntu MAAS DNS not forwarding request for an example where the forwarders are not handling DNSSEC requests correctly. The symptom are errors that look like this in /var/log/syslog:

validating @0x...: com DS: no valid signature found
error (no valid RRSIG) resolving 'com/DS/IN'

If you encounter this, you'll need to either get your forwarders to support DNSSEC, or disable DNSSEC upstream validation in the MAAS settings page.

As to why DNSSEC is enabled by default, see the long debate in bug 1500683.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.