5

I recently installed Ubuntu along with Windows 10. It is working perfectly till today. But I updated my Ubuntu 16.04 form Software Updater and restarted my system.

After restarting I am getting following Error while opening other disk drives (named 136 GB Volume).

enter image description here

Please notice that I am able to access these drives(NTFS partitioned) before updating the system but now it is showing error.

Now I am having access to Computer drive only (that is EXT4).

Please help me to solve this issue. As I am new to Ubuntu.

Thanks!

2
  • Have you hibernated or suspended your Windows before booting Ubuntu? If so, boot to Windows and shutdown properly. – Michal Polovka Sep 4 '16 at 17:21
  • No I just Shut down it. And then I reboot with Windows 10 and working there for more then 2 hours. but When I rebooted it Ubuntu again it is showing Error. – Abhishek T. Sep 4 '16 at 17:23
14

Simply open terminal and type this command

sudo ntfsfix /dev/sda2

you can replace /dev/sda2 by your appropriate drive in which you are facing problem, like in my case there was a same problem with my drive /dev/ada4

4
  • How to know my drive ? , Yup its displaying in error window. – 151291 May 18 '18 at 6:22
  • but not able access windows C drive. mount not permitted. – 151291 May 18 '18 at 6:29
  • 1
    on run this over / where I have issue, I got : Volume is corrupt. You should run chkdsk. – Carmine Mar 13 '19 at 12:40
  • Will this erase the content of the disk? – Trect Feb 20 '20 at 10:52
5

Windows 10 (or Windows 8/8.1), by default, hibernates all drives.

In order to access Windows drives from other OSes in dual boot you need to disable the fastboot default option in Windows.

  1. Option 1

Open Control Panel > Power Options. Click "Choose what the power buttons do" and then "Change settings that are currently unavailable". Under "Shutdown settings", uncheck the Turn on fast startup box, click on the "Save changes" button and shutdown (do not simply reboot because it will reverse the changes).

  1. Option 2 - Edit the registry entry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power and change its DWORD value to 0. Shutdown.

Source: http://www.tenforums.com/tutorials/4189-fast-startup-turn-off-windows-10-a.html

Anyway, you shouldn't be messing with your Windows system partition from Ubuntu. If you need to share files between OSes consider creating another partition (NTFS) just for that. Doing otherwise the chance of your Windows not booting afterwards is very high.

11
  • Good answer, could you please add information how to disable fastboot? – Michal Polovka Sep 4 '16 at 17:25
  • Please Notice it I am having access to those NTFS drives in Ubuntu too before updating. but now (After Update) it is giving Such type of Error. And I just bring it in your notice that I have rebooted my system before it many times with both OS and did not get this Error before now. – Abhishek T. Sep 4 '16 at 17:27
  • @Michal - Done! ;-) – user589808 Sep 4 '16 at 17:36
  • @AbhishekTandon perhaps previous versions never checked if Windows was hibernated and allowed you access which could cause damage. If so then in 16.04 extra protection has been added which is an improvement. Either way your screen clearly shows Windows is hibernated and that is preventing you from accessing data today. – WinEunuuchs2Unix Sep 4 '16 at 17:37
  • @Abhishek Tandon - Please, first of all, consider NOT doing it for the reasons I mentioned. Please read the link I just edited in the answer for more informations about Windows 10. – user589808 Sep 4 '16 at 17:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.