6

Any time I try to open a link from Slack, all I get is a blank new window opening in Chrome. Worth reinstalling, or do others have this problem?

13

I'm on fresh Ubuntu/Chrome/Slack and links were opening blank tabs in Chrome. This AskUbuntu answer worked for me:

Open file: $HOME/.local/share/applications/google-chrome.desktop

Find the line:

Exec=/opt/google/chrome/chrome

Add a space and %U:

Exec=/opt/google/chrome/chrome %U

Then save the file.

  • Particularly, forgetting the argument is an easy mistake to make when creating your own desktop files, so this was exactly what I needed. – Kat May 23 '17 at 18:35
  • its work for me! find file sudo find -name 'google-chrome.desktop' and edit nano ./.local/share/applications/google-chrome.desktop – des1roer Nov 28 '17 at 10:41
2

This was actually a problem with Google Chrome itself. Updated version fixed it.

  • 1
    Can you tell me which Chrome version you're running, that links work in? I'm having this same issue with 16.10 – swajak Jan 30 '17 at 20:17
  • I don't remember which one it was -- I'm using Google Chrome 55.0.2883.87 now and it's been fine. – Nick Sweet Jan 30 '17 at 22:21
  • Thanks. I did end up getting it working, and you reminded me to update this thread. Thanks! – swajak Jan 30 '17 at 22:32
2

To get into the slack I just run slack command in commandline with the magic link as argument.

slack slack://ABCDSF4MR/magic-login/892109304726-LONG_SECRETKEY

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.