13

I am trying to set up an SSHFS connection between two Ubuntu machines, using /etc/fstab so that they automount from the beginning.

I have created an .ssh directory in my home dir on both machines, I have created the id_dsa and id_dsa.pub files, and copied the keys over to each machine in a file called authorized_keys. I have set the directory permissions to 700 and the files to 600.

I have edited /etc/fuse.conf so that user_allow_other is uncommented.

This is the format of my entry in /etc/fstab on the client machine, which I got from here:

sshfs#[email protected]:/home/myname    /mnt/sshfs/homebox    fuse    comment=sshfs,noauto,users,exec,uid=1000,gid=1000,allow_other,reconnect,transform_symlinks,BatchMode=yes 0 0

However, whenever I try to mount the server, I get this error:

fusermount: failed to open /etc/fuse.conf: Permission denied
fusermount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf

As mentioned, I have already uncommented user_allow_other, so this error is extra puzzling.

What else do I need to do?

1 Answer 1

20

Is your user a member of group fuse?

If not, please do:

~$ sudo adduser $USER fuse

Try to take a look at the permissions of the file:

~$ ls -l /etc/fuse.conf

It should be like this:

~$ -rw-r----- 1 root fuse 216 2011-05-18 07:12 /etc/fuse.conf

If not, please, correct it.

~$ sudo chmod 640 /etc/fuse.conf

Don't forget to logout and login again after adding your user to the group fuse.

Let me know if it solved your problem.

Regards.

7
  • This has worked, but one question: There are now two Mythbuntu entries in the "Places" menu in my gnome panel. Is that normal?
    – Questioner
    Nov 23, 2011 at 16:52
  • hmm, can you post a screenshot? Nov 23, 2011 at 17:11
  • Oh, just remembered one thing. Do you have this location set as a Bookmark in Nautilus? Maybe that's the reason. Delete the bookmark. Nov 23, 2011 at 17:12
  • Sorry, just to be clear, the computer I am trying to connect to is called "Mythbuntu", which I didn't mention clearly earlier. Anyway, the thing is that right now there is one entry for Mythbuntu under "Devices", and one entry under "Computer". If I click the icon under "Devices", it says "Unable to mount Mythbuntu". However, if I click the icon under "Computer", everything works fine. So, the directories and files are available, but I'm just concerned that this additional, non-working, entry is symptomatic of a problem.
    – Questioner
    Nov 24, 2011 at 1:38
  • Please, can you change your fstab line, the options column to "user,noauto,transform_symlinks" only, reboot and check if the problem still occurs? Nov 24, 2011 at 15:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .