I have downloaded the cav-linux_x64.deb from their official site and when I try to install using GDebi Package installer it says dependency not satisfied(libssl0.9.8). When I try installing using terminal it says

(Reading database ... 234555 files and directories currently installed.)
Preparing to unpack .../Downloads/cav-linux_x64.deb ...
Unpacking cav-linux (1.1.268025-1) over (1.1.268025-1) ...

Uninstallation succeed!

dpkg: dependency problems prevent configuration of cav-linux:
 cav-linux depends on libssl0.9.8 (>= 0.9.8m-1); however:
  Package libssl0.9.8 is not installed.

dpkg: error processing package cav-linux (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

And when I tried to install libssl0.9.8 it says

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libssl0.9.8 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libssl0.9.8' has no installation candidate**

When I checked the packages for 16.04 I found that that package is not included for 16.04. What should I do to install Comodo on my Laptop?

Acer 4736z 64 bit with intel pentium dual core and 3 gb RAM.

Thanks in advance

  • Linux doesn't really need antivirus. That's the beauty of it. If you are really worried, you could install rkhunter. Sep 4, 2016 at 11:07
  • Android Dev there are many viruses available on Linux, and another way to get infected is to use Wine since windows viruses might be transfered to linux using this tool
    – Tomas
    Sep 4, 2016 at 11:10
  • I am not worried about my Linux getting infected.I have windows systems which may get infected.I would like to install Comodo but if nothing works, I may go for rkhunter. Also being Linux wont protect me from Phishing or other online threats
    – Vineeth
    Sep 4, 2016 at 11:12
  • I am aware of Linux viruses and Mint was Hacked recently
    – Vineeth
    Sep 4, 2016 at 11:19
  • @Rinzwind , Do you think Linux will warn me of a Malicious website or any Phishing mails? Security can get compromised at various levels.User being the most frequent cause.Rather than making this a discussion of weather Linux needs antivirus or not, please help me figure out what went wrong.
    – Vineeth
    Sep 4, 2016 at 11:28

2 Answers 2


The libssl version on 16.04 is newer than Comodo wants. By the way: ours is newer due to security fixes (...) so the Comodo package you used is too old for 16.04. Comodo got an update on the 31st of August. Make sure you download the latest version as this is more likely to fix the dependency.

If you still get the dependency problem you will need to install an older version manually. You can find the version from precise here. Use dpkg to install this and then install Comodo.

Mind also that the only real use case for anti-virus software is to scan files before you send them to Windows machines. It will not find any virus inside Linux files (since we do not download random software from the web and download software from our repositories and as those are virus free we don't need a virus scanner).

Regarding things in comments:

It will also not prevent phishing nor will it prevent you from problems related to malicious websites. There are other tools for that. For those you have rkhunter, ispprotect (Website malware scanner), chrootkit, lynis and several more. Also be aware that most of those rootkit scanners are also flawed (99.99% of what they claim is a problem is a false positive) and it is best to use 2 or more rootkit scanners and compare results. When 2 or more believe there is a problem you might have one. If only 1 does it is very very likely a false positive.


Requested package libssl0.9.8 is on https://packages.ubuntu.com/trusty/amd64/libssl0.9.8/download I had on my pc libssl1.0.2, but the system accepted also v.0.9.8 This was for me a surprise. Then I have locked the older version libssl (against update) in synaptic and it was no obstacle to install Comodo 64. The older libssl was for Ub 14.04 trusty, but neither this was problem. I have Ub.16.04. Comodo runs very good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.