1

EDIT: New Update Crashes network manager My question is a duplicate to some extent; the answer there din not solve my problem

I got this weird problem where my machine cannot find any networking. Not even the wi-fi symbol appears on the taskbar. $service network-manager stop unrecognized command.

machine: Dell Inspiron 5551 version A03

os: Ubuntu 14.04 LTS (came with the laptop from factory)

Story: I ran the update it got stuck for an hour and a half on installing grub update; I rebooted-> Critical Error. Reinstalled OS from factory image. It got stuck at the end at the logs 1 hour passes. I rebooted->it worked but it cannot find the network hardware. I tryed to install a different version of ubuntu but during the installation it said it could not set up a network and it is recommended that I go back on the previous step. I aborted the new installation, currently running the os I have mentioned under the machine.

On startup under Ubuntu loading screen: Waiting for network configuration; Waiting up to 60 seconds for network configuration...

I have lurked a bit on google on similar related problems but I could not manage to troubleshoot it.

I have decided to ask for help here, can anyone help me find a solution to my problem and make the networking work again so I can connect to the internet?

$sudo lshw -c network

*-network DISABLED description: Wireless interface product: Wireless 3160 vendor: Intel Corporation logical name: wlan0 version: 83 driverversion=3.13.0-38

$iwconfig

lo no wireless extensions

wlan0 IEEE 802.11abgn ESSID:off/any Mode:Managed Access Point: Not-Associated Tx-Power=0 dNm Retry short limit:7 RTS thr:off Fragment thr:off Power Management:on

$dmesg | grep -i iwlagn

nothing -> So i guess here is the problem. No driver;

EDIT

$dmesg | iwl

iwlwifi 0000:02:00.0: irq 106 for MSI/MSI-X iwlwifi 0000:02:00.0: loaded firmware version 23.214.9.0 op_mode iwlmbm iwlwifi 0000:02:00.0: Detected Inter(R) Dual Band Wireless AC 3160, REV=0x164 iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S

/etc/network/interfaces

added the following lines:

auto wlan0 iface wlan0 inet dhcp

$sudo ifdown wlan0 && sudo ifup -v wlan0

Listening on LPF/wlan0:34:de:1a:9c:bd:af Sending on LPF/wlan0:34:de:1a:9c:bd:af Sending on Socket/fallback ifup: failed to open lockfile /run/network/.ifstate.lock: Permission denied

found this bug fix-up for the Permission denied encountered earlier.

$sudo restart networking

-> restart: Job failed to restart

$sudo /etc/init.d/networking restart.

nothing happened apparently i got other bug

$sudo nmcli nm enable false

process:2916: WARNING: Could not initialize NMClient /org/freedesktop/NetworkManager: The name org.freedesktop.NetworkManager was not provided by any .service files

Found this: New Update Crashes network manager My question is a duplicate to some extent

The problem still persists. Got errors when installing libnl. Managed to use apt-get -f install the wireless symbol appeared on the taskbar but the Wi-Fi networks otpion is gray and cant be selected, same with device not managed;

answer to user chili555

$rfkill list all

0: phy0: Wireless LAN Soft blocked:no Hard blocked:no 1: hci0: Bluetooth: Soft blocked:no Hard blocked:no

$lsmod | grep dell

dell_led dell_wmi sparse_keymap dell_laptop dcdbas wmi

Did a reboot Now the wireless symbol does not show anymore on the taskbar.

Locally downloaded network-manager.deb installed network-manager got the following errors: dpkg: error processing package network-manager locale: cannot set LC_CTYPE to default locale: no scuh file or directory locale: same of LC_messages and LC_All

report for chili555: I reverted the changes to /etc/network/interfaces did a reboot now no longer said waiting for network while ubuntu loaded but no wifi symbol in taskbar.

pastebin for chili555: http://paste.ubuntu.com/23129565/ refering to this

EDIT2

Tryed running in safe mode -> mount network -> Segmentation fault

Now I am trying to revert to factory image. Failed.

Doing a clean install of ubuntu 16.0.4.1 erased everything -> all working fine now. But the problem has not been solved, had to reinstall.

  • Probably you need to install some drivers package from Dell. But, considering you're reinstalling, why not test the current LTS - 16.04 -? Chances are it will just work. – user589808 Sep 3 '16 at 14:52
  • I unfortunately cant find the drivers packages from Dell :< Maybe I will give a try to the new LTS after I try to fix this. – M.F.Crist Sep 3 '16 at 15:14
  • That's service, not services, right? – ubfan1 Sep 3 '16 at 15:16
  • yes service network-manager restart -> network-manager: unrecognized service – M.F.Crist Sep 3 '16 at 15:21
  • Disabled usually means the switch or key combination is set to disable wireless. What does this tell us? rfkill list all and also: lsmod | grep dell – chili555 Sep 3 '16 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.