I've been doing research for a couple hrs now to solve this problem and have found nothing that works. Ex: this does not work for me: xUbuntu Default desktop Icons do not display?

Here is a screenshot of my Display settings:

Notice that even though I have Home, Filesystem, Trash, and all Removable Devices selected to show up, none of them do. How do I make them show back up again like they used to?

Note: I use nemo as my default file manager; I don't know if that's related. All of this began when my computer went to sleep while it was connected to a network drive, and I woke it back up again. This caused it to freeze, so I logged off then back on, then was forced to restart. See my comment on that under this answer here: https://askubuntu.com/a/764120/327339. Upon restarting, and after many restarts and completely turning it off since then, my default desktop icons remain disappeared.

enter image description here

Also note that even the icons you see on my desktop above do NOT show up when I first boot. They only appear AFTER I open up my nemo file manager at least one time after booting.

This does NOT work either: Xubuntu 16.04 all icons disappeared after update.

Nor does this: https://askubuntu.com/a/302022/327339

  • Since you are using XFCE, the Desktop is managed by Thunar. Did you change this setting to Nemo, when you changed your default file manager to it? If yes, then your current settings window from where you are trying to change the icons won't work.
    – Raphael
    Sep 3, 2016 at 5:22
  • I did change the default file manager to nemo, yes, by going to Start menu --> Settings Manager (search for it) --> Preferred Applications --> click "Utilities" tab at the top --> set File Manager to "nemo" from the dropdown menu. Sep 3, 2016 at 5:28
  • Related question No desktop icons after update to 14.04 Dec 27, 2016 at 21:04

3 Answers 3


Ok, I tried a whole bunch of things to my own question, over the course of about 2 hrs, so I'm not 100% sure something I did before this wasn't part of the solution, but this worked for me:

In a terminal, do:

rm -R ~/.cache/sessions/*
sudo reboot

Source: Desktop icons not showing up in xubuntu (and I cant right click on the desktop)

Once I did the above and my icons all came back, I changed my background back to the original one, as it was one of the fancy photos after doing the commands above. Here's what it looks like now:

enter image description here

I think I also did the following things before doing the commands above, but I do not think they were necessary. Nevertheless, I'll include them here for completeness' sake in case they were unknowingly part of the solution:

sudo apt-get install --reinstall xubuntu-desktop
sudo apt-get install --reinstall tango-icon-theme tango-icon-theme-common

...along with many restarts as I tried various things. And I uninstalled nautilus too via sudo apt-get remove nautilus, as I had previously installed it as well.

  • Has your problem solved?
    – Anwar
    Sep 3, 2016 at 10:21
  • 1
    Yes, but I can't upvote my own answer, and I can't mark my answer as the correct one for 2 more days. Sep 3, 2016 at 16:32
  • 2
    reboot was not necessary for me 17.04, simple rm-rf kill cache sessions & restart xdesktop.
    – shadowbq
    Sep 11, 2017 at 11:45

I had your same problem and also I could not right click on the desktop. I fixed this by using the Tweak Tool, apparently after an update the tab "Icons on desktop" was set to Off. I turned it On and everything went back to normal. I took this solution from here.


I had this problem whilst transferring my wifes system to a new machine. Desktop wallpaper present with no icons. top status bar populated and command line available.

Combining information from several posts into a small script in case it pops up again and I'm not around to fix. This is for Xubuntu 16.04, so adapt for your flavor and enjoy.


# Run to restore desktop
echo ".. Should be run by affected user"
echo "Replacing desktop with command"
echo "... xfdesktop replace"
 xfdesktop replace
echo "Deleting  ${HOME}/.cache/sessions/*"
echo "... rm -R ${HOME}/.cache/sessions/*"
 rm -R ${HOME}/.cache/sessions/*
echo ". Done, please log off and on to see effect if this worked."
echo ". Goodbye"
# comment out if no pause wished
 sleep 2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .