0

My 64gb Sandisk Cruzer Glide Usb drive freezes my linux desktop partition tools such as GParted, and also tends to freeze windows partitioning applications. I cannot do anything to the usb drive other than using the command:

sudo dd if=/dev/zero of/dev/sda1 bs=512 count=32

Any suggestions?. Also when I go to GParted, the message end of file while reading /dev/sda appears. How should I fix this?

4
  • Have you tried on a different computer? The stick might just be defective. – jawtheshark Sep 2 '16 at 19:46
  • I've tried it on a windows computer and my linux computer, it doesn't work on any computer. That usb was working before I used dd to write ubuntu to my usb – Jeremy Silva Sep 2 '16 at 19:48
  • I know a usb can sometimes get corrupted due to writing an image to it, yet I have tried everything. – Jeremy Silva Sep 2 '16 at 19:51
  • What do you do when the message appears? I.e. did you just start gparted, and saw the message, or does it appears when you're trying to create a partition? Also, unplug the drive, execute in the terminal tail -f /var/log/syslog, plug the drive, and add to the post all the output that would appear. – Hi-Angel Sep 2 '16 at 20:39
0

I ran into a similar issue and after doing a lot of research I found How do I fix my USB drive to get its original 8GB size back?

Now please be sure to use this with extreme caution as you can end up accidentally formatting the wrong device. This occurred when Windows attempted to "Fix" a USB Drive that was plugged into a Linux system from before.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.