I'm running Ubuntu 11.04 on my laptop and try to use a network printer.

Adding the printer to Ubuntu works without problems but when I try to print something the print job stays in the queue and nothing happens. Then I realized that the printer is not enabled. But enabling leads to an error message saying:

There was a problem sending document 'Test Page' (job 6) to the printer.

When clicking the "Diagnose" button and clicking through the Printing Troubleshooter it says I should enable the printer what I'm already trying to do. So I'm stuck.

Any ideas what I can do?

UPDATE: Here the output of the error_log that gets written when trying to print a test page.

E [23/Nov/2011:15:23:19 +0100] [Job 8] No %%BoundingBox: comment in header!
E [23/Nov/2011:15:23:19 +0100] [Job 8] Unable to locate printer 'BRN001BA93A3D6F'!
D [23/Nov/2011:15:23:19 +0100] [Job 8] The following messages were recorded from 15:23:19 to 15:23:19
D [23/Nov/2011:15:23:19 +0100] [Job 8] Adding start banner page "none".
D [23/Nov/2011:15:23:19 +0100] [Job 8] Adding end banner page "none".
D [23/Nov/2011:15:23:19 +0100] [Job 8] File of type application/postscript queued by "florian".
D [23/Nov/2011:15:23:19 +0100] [Job 8] hold_until=0
D [23/Nov/2011:15:23:19 +0100] [Job 8] Queued on "Brother-MFC-8880DN" by "florian".
D [23/Nov/2011:15:23:19 +0100] [Job 8] job-sheets=none,none
D [23/Nov/2011:15:23:19 +0100] [Job 8] argv[0]="Brother-MFC-8880DN"
D [23/Nov/2011:15:23:19 +0100] [Job 8] argv[1]="8"
D [23/Nov/2011:15:23:19 +0100] [Job 8] argv[2]="florian"
D [23/Nov/2011:15:23:19 +0100] [Job 8] argv[3]="Test Page"
D [23/Nov/2011:15:23:19 +0100] [Job 8] argv[4]="1"
D [23/Nov/2011:15:23:19 +0100] [Job 8] argv[5]="PageSize=Letter job-uuid=urn:uuid:cb5143f4-2b18-398d-5ce8-bb41f8ff3539 job-originating-host-name=localhost time-at-creation=1322058199 time-at-processing=1322058199 AP_D_InputSlot="
D [23/Nov/2011:15:23:19 +0100] [Job 8] argv[6]="/var/spool/cups/d00008-001"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[0]="CUPS_CACHEDIR=/var/cache/cups"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[1]="CUPS_DATADIR=/usr/share/cups"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[2]="CUPS_DOCROOT=/usr/share/cups/doc-root"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[3]="CUPS_FONTPATH=/usr/share/cups/fonts"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[4]="CUPS_REQUESTROOT=/var/spool/cups"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[5]="CUPS_SERVERBIN=/usr/lib/cups"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[6]="CUPS_SERVERROOT=/etc/cups"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[7]="CUPS_STATEDIR=/var/run/cups"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[8]="HOME=/var/spool/cups/tmp"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[9]="PATH=/usr/lib/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[10]="SERVER_ADMIN=root@pickwick"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[11]="SOFTWARE=CUPS/1.4.6"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[12]="TMPDIR=/var/spool/cups/tmp"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[13]="USER=root"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[14]="CUPS_SERVER=/var/run/cups/cups.sock"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[15]="CUPS_ENCRYPTION=IfRequested"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[16]="IPP_PORT=631"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[17]="CHARSET=utf-8"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[18]="LANG=en_US.UTF-8"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[19]="PPD=/etc/cups/ppd/Brother-MFC-8880DN.ppd"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[20]="RIP_MAX_CACHE=auto"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[21]="CONTENT_TYPE=application/postscript"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[22]="DEVICE_URI=lpd://BRN001BA93A3D6F/BINARY_P1"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[23]="PRINTER_INFO=Brother MFC-8880DN"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[24]="PRINTER_LOCATION=BRN001BA93A3D6F"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[25]="PRINTER=Brother-MFC-8880DN"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[26]="CUPS_FILETYPE=document"
D [23/Nov/2011:15:23:19 +0100] [Job 8] envp[27]="FINAL_CONTENT_TYPE=application/vnd.cups-postscript"
D [23/Nov/2011:15:23:19 +0100] [Job 8] Started filter /usr/lib/cups/filter/pstops (PID 22189)
D [23/Nov/2011:15:23:19 +0100] [Job 8] Started backend /usr/lib/cups/backend/lpd (PID 22190)
D [23/Nov/2011:15:23:19 +0100] [Job 8] STATE: +connecting-to-device
D [23/Nov/2011:15:23:19 +0100] [Job 8] Looking up "BRN001BA93A3D6F"...
D [23/Nov/2011:15:23:19 +0100] [Job 8] Page = 612x792; 12,12 to 600,780
D [23/Nov/2011:15:23:19 +0100] [Job 8] slow_collate=0, slow_duplex=0, slow_order=0
D [23/Nov/2011:15:23:19 +0100] [Job 8] Before copy_comments - %!PS-Adobe-3.0
D [23/Nov/2011:15:23:19 +0100] [Job 8] %!PS-Adobe-3.0
D [23/Nov/2011:15:23:19 +0100] [Job 8] %%Title: PPR Test Page
D [23/Nov/2011:15:23:19 +0100] [Job 8] %%Pages: 1
D [23/Nov/2011:15:23:19 +0100] [Job 8] %%DocumentNeededResources: font Helvetica
D [23/Nov/2011:15:23:19 +0100] [Job 8] %%EndComments
D [23/Nov/2011:15:23:19 +0100] [Job 8] Set job-printer-state-message to "No %%BoundingBox: comment in header!", current level=ERROR
D [23/Nov/2011:15:23:19 +0100] [Job 8] Before copy_prolog - %%BeginProlog
D [23/Nov/2011:15:23:19 +0100] [Job 8] Before copy_setup - %%BeginSetup
D [23/Nov/2011:15:23:19 +0100] [Job 8] Before page loop - %%Page: 1 1
D [23/Nov/2011:15:23:19 +0100] [Job 8] Copying page 1...
D [23/Nov/2011:15:23:19 +0100] [Job 8] PAGE: 1 1
D [23/Nov/2011:15:23:19 +0100] [Job 8] pagew = 587.9, pagel = 767.9
D [23/Nov/2011:15:23:19 +0100] [Job 8] bboxx = 0, bboxy = 0, bboxw = 612, bboxl = 792
D [23/Nov/2011:15:23:19 +0100] [Job 8] PageLeft = 12.0, PageRight = 599.9
D [23/Nov/2011:15:23:19 +0100] [Job 8] PageTop = 780.0, PageBottom = 12.1
D [23/Nov/2011:15:23:19 +0100] [Job 8] PageWidth = 612.0, PageLength = 792.0
D [23/Nov/2011:15:23:19 +0100] [Job 8] Backend returned status 4 (stop printer)
D [23/Nov/2011:15:23:19 +0100] [Job 8] Printer stopped due to backend errors; please consult the error_log file for details.
D [23/Nov/2011:15:23:19 +0100] [Job 8] End of messages
D [23/Nov/2011:15:23:19 +0100] [Job 8] printer-state=5(stopped)
D [23/Nov/2011:15:23:19 +0100] [Job 8] printer-state-message="Unable to locate printer 'BRN001BA93A3D6F'!"
D [23/Nov/2011:15:23:19 +0100] [Job 8] printer-state-reasons=paused
  • 1
    Is there more information (e.g. error messages) in /var/log/cups/error_log?
    – tohuwawohu
    Nov 23, 2011 at 11:19
  • 2
    @Flo - the error message says that it cant find the printer... how have you installed the printer-driver? You'll probably need to access it via an IP address. Can you add some screenshots to your question showing the printer configuration applet?
    – fossfreedom
    Nov 23, 2011 at 14:51

7 Answers 7


OK I got the printer working. After reading @fossfreedom's comment I looked again at the add printer applet.

The last time I tried to add the printer I searched for it by clicking "Find Network Printer" under "Network Printer" and selected the printer in the list of available printers in the network.

This time I also clicked "Find Network Printer" but I also entered the printer's IP and clicked "Find" which shows another entry in the list "JetDirect ...". I selected this printer and finished the installation wizard.

It worked!

  • So much thanks, Flo. I bought the brother DCP-J140w and I had the same problems on Ubuntu 12.04. Just take "AppSocket/HP JetDirect" option on the printing Wizard and write the IP printer and printer runs. Carlos.
    – user139234
    Mar 10, 2013 at 21:29
  • Please see my answer to see how to avoid having to enter the IP as well as avoid problems when the IP changes. Apr 28, 2014 at 10:35
  • In my case, when I used the "found" printer, I also got "Unable to locate printer [printer ID]". I instead had to manually specify ipp://ipaddressofprinter/ipp. Then it just worked.
    – Pistos
    Apr 6, 2016 at 1:51
  • 1
    Note that if you put a trailing slash like this, it may not work (depends on the printer model, I think): ipp://ipaddressofprinter/ipp/
    – Pistos
    Apr 6, 2016 at 12:50
  • Through the help of this answer I got it worked too, however, I chose "docu print*" instead of "JetDirect" Mar 7, 2019 at 2:38

You always need to have nss-mdns (libnss-mdns, depending on distribution) installed and you need to have mdns in the hosts line in /etc/nsswitch.conf to print via DNS service discovery. I guess it's too late for the original poster but I googled this page when looking for the solution.

hosts:       files mdns_minimal dns mdns

You also need to have avahi-daemon running to provide the backend for multicast DNS.

  • 1
    This worked for me.
    – nibot
    Sep 25, 2020 at 21:08

You can try unpausing the printer (this happens to me with network printers in Ubuntu occasionally).

Try opening the CUPS web interface at http://localhost:631 and selecting the Printers tab. There click on the printer's name and select the resume printer option from the Maintenance drop-down menu.

Source: this Ubuntu forums post.


Nothing from other advices really worked. What helped to me was to change IP address of the network printer to the local network settings. Network printer was second-hand and there was completely different IP settings (like outside my local network). Windows computer was able to print on it, but Ubuntu not. After repairing the IP settings, IP, subnetmask, Default gateway, nameserver (to local network) Wins and domain (cleared) was printer detected differently and i was able to print from ubuntu.

Network printers are usually able to print their network settings and they are usually manageable over web by entering the IP address into a web browser.

Most probably some DNS magic which was recommended by Pavel Šimerda was missing on my Ubuntu (if exist).


Just in case you're in my situation: restart the printer

I installed a network brother printer using DeviceURI, with dnssd provided automatically. The install had no problem, but ubuntu said "unable to locate" the printer. After trying many things, I simply restarted the printer and it went on printing what was in the queue.

So before anything complicated, if you can, restart it the printer first.

Now, I have no idea why that worked. Something else also changed: before I restarted the printer, I couldn't ping my printer nor had access to its http page (putting its ip in my browser address bar). And now both work. So its seems the printer refused connection until I restarted it.


I have same problem following step help me to reconnect to printer.

  1. Press window button and search for printer.
  2. Right click on your and go to properties.
  3. Click on changes device UPL it will show your printer just select your printer and press apply.
  4. Now you can print your documents.

I had to use lpoptions to get it to work for me. I went to the printer control panel to find the name of the printer queue, Color-LaserJet-2830 in my case, and I typed: lpoptions -d Color-LaserJet-2830

Magically, everyone could see my printer, including Print Preview.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .