1

So recently, like 2 months after installing ubuntu 16.04, all of my games that I run from the terminal spam the terminal with this message:

../../../../src/intel/isl/isl.c:232: FINISHME: isl_surf_choose_tiling: gen6

Any Idea on how to fix it? I am using Oibaf Graphics drivers, and considering switching back to Windows.

Also from then, I have been experiencing weird fps issues in Minecraft. I never had fps issues in minecraft...

2
  • 2
    Your post consists of 2 separate questions. I suggest asking the Minecraft question separately if there are no duplicates. The site does get some number of Minecraft questions and answers that may be relevant to you. – edwinksl Sep 2 '16 at 17:38
  • 1
    Elderzz, check out askubuntu.com/search?q=%5Bminecraft%5D+fps for a bit more reading on the second question. And @edwinksl is right, it would be better as another question. – anonymous2 Sep 2 '16 at 17:41
2

I encountered this issue when I was running matlab in the terminal. Specifically, running matlab -nodesktop -nosplash and then the plot function (or any function that uses OpenGL) gives a bunch of ../../../../src/intel/isl/isl.c:242: FINISHME: isl_surf_choose_tiling: gen6 messages.

You are seeing these messages because you are using the Oibaf PPA. There is a new patch at https://patchwork.freedesktop.org/patch/107575/ that will remove these messages, but it is not accepted yet. So, if you truly want to remove these messages, you can use ppa-purge to remove the Oibaf PPA for now by running:

sudo apt install ppa-purge  # do this if you don't have ppa-purge
sudo ppa-purge ppa:oibaf/graphics-drivers

A way to suppress these warnings is to redirect stderr to /dev/null by starting the program of interest as follows:

program-of-interest 2> /dev/null

As @Zanna points out, you can alternatively redirect stderr to a file and then grep the file for errors of interest:

program-of-interest 2> /path/to/file

In the specific case of matlab which functions as a REPL in the terminal, redirecting stderr to /dev/null causes useful warnings (e.g. syntax errors, undefined variables, etc.) to be suppressed. Redirecting stderr to a file and then grep-ping the file also somewhat defeats the purpose of using a REPL. If your program of interest isn't a REPL and is instead, say, a game, then both ways are still useful.

2
  • 1
    Probably this is a completely unhelpful note, but if there's a chance you might want to see the warnings from the program, you could redirect stderr to a file instead of /dev/null and grep through it later if necessary? – Zanna Sep 15 '16 at 7:22
  • @Zanna That would be a good idea for some programs but not for matlab because matlab functions as a REPL and having to grep a file later defeats the purpose of using a REPL. But you raised a good point and I should account for programs that may find grepping such a file useful. :) – edwinksl Sep 15 '16 at 7:24
1

That terminal message looks like status of some sort. If you run things from the terminal, they're going to output messages.

Since you're running games from the terminal, you're going to see a lot of those, as games tend to render things and report the success or failure of that render operation. There really isn't a good reason I can think of for running games from the terminal, and you haven't provided your thought process behind that decision. If it was because you wanted status reports, well, you got 'em.

If you want the terminal to not report anything (this doesn't always work), you can use this command:

PROGRAMNAME &> /dev/null &

The ampersand at the end will return the terminal to a prompt. If you want to be able to exit the game using Ctrl+C in the terminal, just remove it.

As for Minecraft's FPS issues, you really should ask that in a separate question, and actually ask a question on how to fix it, instead of just saying it doesn't work. If you want us to help you, you need to help us first, by providing us with details, reasons, and context. Maybe try uninstalling Oibaf's driver and just using the default Intel one.

1
  • That is what I did. I installed the default intel ones, (didnt work), installed them using intels driver update utility(still lagging), installed oibafs(still no success) Now, Im in process of reinstalling oibaf drivers. To see if that helps – Elderzz Sep 2 '16 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.