41

I use GNOME Classic. There is no Ctrl+Alt+Left/Right shortcut in System Settings -> Keyboard -> Shortcuts.

enter image description here

It should be configured somewhere else. But where?

6 Answers 6

62

Remove the default keybinding using the following commands

 gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-left "['']"
 gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-right "['']"
5
  • 1
    Using gnome-shell on Arch, and this is the only answer that worked for me. Jun 1, 2014 at 20:34
  • 2
    Had to do this in order to use this shortcut for other apps in ubuntu 18.04. Note that in ubuntu 18.04 (today 2018-05-22) there is no left or right workspace by default and there is no way to configure this shortcut via graphical settings
    – Qlimax
    May 22, 2018 at 8:38
  • 2
    On recent gnome-shell is not possible to have left and right workspaces but keybinding is still active (and clashing with Intellij IDEA defaults). Dec 4, 2018 at 11:12
  • 2
    If you prefer a GUI editor, you can run dconf-editor instead of the above gsettings commands. In the editor, navigate to the same path (/org/gnome/desktop/wm/keybindings).
    – seairth
    Dec 31, 2019 at 16:31
  • gsettings still works on ubuntu 18.04, but it requires to restart gnome-shell to apply the new bindings (Alt+F2, r, <enter>) Feb 4, 2020 at 14:12
19

In my system, those configs are available in System Settings -> Keyboard. Please double-check.

enter image description here

If those aren't available, you can try add them with gconf-editor. If you use Metacity, simply go to /apps/metacity/global_keybindings and add the corresponding values:

enter image description here

If you use Compiz, you can follow the steps provided by @ams

2
  • I don't have these items, see my screenshot
    – geevee
    Nov 23, 2011 at 12:53
  • updated, i hope it helps
    – Salem
    Nov 23, 2011 at 14:17
4

CompizConfig Setting Manager (it's not installed by default though).

Then go to "Desktop Wall Plugin", and it's on the "Bindings" tab.

That's assuming you are using Unity (full 3D), or (edit) Gnome with effects enabled.

3
  • No, I'm not using Unity, I am using GNOME Classic.
    – geevee
    Nov 23, 2011 at 12:54
  • Sorry, I missed a few words I meant to type .... I'll correct it above.
    – ams
    Nov 23, 2011 at 12:57
  • This worked! Thanks!
    – Wojtek
    Jun 2, 2021 at 14:58
2

Finally, in Ubuntu 22/04 this can be disabled using System Settings -> Keyboard -> View and Customize Shortcuts -> Navigation. In there, find Move to workspace on the left and Move to workspace on the left, click on each entry and re-assign Super+Page Up and Super+Page Down respectively. This will disable any other assigned shortcuts.

2
  • I'm using Ubuntu 22.04, following Customize Shortcuts and set Move to workspace to left to Super+Page up, but this does not disable Ctrl+Shift+Left to be working at the same time... Any idea how I can disable it?
    – WillZ
    Sep 29, 2022 at 21:51
  • Works in Ubuntu 22.10. Finally using it in PHP Storm again. Although I had to assign it there, as Navigate back is assigned to Shift Alt Left on Linux and Ctrl Alt Left on Windows.
    – Jan Derk
    Jan 5 at 18:43
1

open gconf-editor.

Go to /apps/metacity/global keybindings and change the values according to my screenshot:enter image description here

0
0

on ubuntu 22:

whenever i was pressing ctrl alt left/right my workspace would move.

However, in the keyboards settings I did not have such a shortcut set but i had one for each:

a. Move workspace on the left ; shortcut: ctrl + alt + up (wtf)

b.Move workspace on the right: ctrl + alt + down (wtf again)

when i disabled the above two ctrl+alt+left/right stopped working as well.

.. quite interesting one might add ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.