2

Problem description : I have followd a guide to Install the Battlenet client on ubuntu. After that i installd it via Browser (Firefox->download->install) Now when i want to start the client it shows "Starting battlenet" the Loading bar gets to a 100% and than it cancels the client without an error massage or any other information what so ever.

Ive tryd to solve my problem with the guide described in another similar question in this forum ( Battle.net Won't Open) i have followed the steps and it still wont work. same problem.

My thoughts next are that maybe i have to uninstall and re-install the client because i have followed the problem solving steps after the client was already installd , problem is i dont know how to de-install it. I have followed several instructions like the purge command or dkpg-l (command not found)

Im really new to linux and also not an native english speaker so forgive me my bad english and even worst linux knowledge.

Thank you in advance

1
  • uninstalld and re installd battlenet client (found out how to) still no change problem remains unsolved Sep 5, 2016 at 8:26

1 Answer 1

2

The new battle.net client has new requirements. Here's how I got it installed:

  1. Create a separate wine prefix for battle.net (replace user with your username)
    export WINEPREFIX=/home/user/.wine_battlenet
    This sets the wine prefix to the specified directory for the currently open terminal.
  2. Run winecfg, select Windows XP as the OS and on the Libraries tab, add an override for msvcp140 (native, builtin). Click Apply and close the configuration. library to add
  3. In the same terminal run winetricks corefonts to install the default Microsoft fonts.
  4. At this point installing battle.net should work without problems.
    wine Battle.net-Setup.exe
  5. You should get a desktop icon (which automatically uses the wine prefix) and everything should work as expected.
6
  • Does this still work or does it need updating? I tried using the old way of using PlayOnLinux and then modifying the list of libs but that didn't work this time.
    – user447607
    Apr 4, 2017 at 22:54
  • @user447607 is stopped working with the latest Battle.net-Update. What fixed it was setting winecfg to WindowsXP.
    – mniess
    Apr 7, 2017 at 18:36
  • I'll try that later. Weird though. Downgrading is counter intuitive. Same libs?
    – user447607
    Apr 7, 2017 at 19:14
  • @user447607 yes, changed nothing else.
    – mniess
    Apr 9, 2017 at 18:37
  • Worked for me. Make it an answer and I'll accept.
    – user447607
    Apr 9, 2017 at 22:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .