I have ubuntu 16 LTS. Virtualbox could run, but I have removed it. After some time, I update kernel to 4.7.2. Installing Virtualbox again but it does not boot the guest system. It shows this message:

Kernel drive not installed rc=1908

It tells me to rin /sbin/vboxconfig, but the script fails:

vboxdrv.sh: Building VirtualBox kernel modules. vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong.

There were problems setting up VirtualBox. To re-start the set-up process, run /sbin/vboxconfig as root.

This is the log file:


What should I do to make Virtualbox work again?


  • VBox version? You may need the latest release to support installing on a brand new host kernel.
    – Takkat
    Sep 2, 2016 at 10:12
  • I have tried the apt-ger version, and also the deb file from Virtualbox website. Both does not work after kernel update. Sep 2, 2016 at 10:49

5 Answers 5


Based on a discussion on Ubuntu Forums, the following worked for me when I upgraded kernel in Ubuntu:

$ sudo dpkg-reconfigure virtualbox-dkms && sudo dpkg-reconfigure virtualbox && \
    sudo modprobe vboxdrv
  • I really wish I could make that automated after an update somehow. This is the answer that I keep coming back to and that works.
    – cav_dan
    Nov 22, 2017 at 17:42
  • Works fine on Ubuntu and Debian without rebooting.
    – abu_bua
    Mar 12, 2022 at 0:40

On Fedora, I've been doing a /usr/sbin/vboxconfig after kernel updates, it seems to do a good job of rebuilding the kernel drivers after kernel updates.

  • it is likely a conflict between old script and new headers as some commands are obsoleted.
    – ravery
    Sep 14, 2017 at 9:29

I would uninstall and then re-install VirtualBox:

sudo apt purge virtualbox*
wget http://download.virtualbox.org/virtualbox/5.1.4/virtualbox-5.1_5.1.4-110228~Ubuntu~xenial_amd64.deb
sudo dpkg -i virtualbox-5.1_5.1.4-110228~Ubuntu~xenial_amd64.deb

Your guests will not be deleted and should appear when you open VirtualBox. You may have problems with the guest network interfaces after re-installing VirtualBox. If you do, just disable the network interface, start the guest, stop the guest, then re-enable the network interface.

  • after typing in dpkg, during the installation, it shows: " vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong. There were problems setting up VirtualBox. To re-start the set-up process, run /sbin/vboxconfig as root." Sep 2, 2016 at 10:48
  • Have you made sure no guests are running? Perhaps try uninstalling using the Software Centre. If that fails, you could always try to force the uninstall: sudo apt-get --force-yes remove virtualbox-5.1 Sep 2, 2016 at 12:44
  • Sorry, just re-read your comment - was the uninstall successful? Is it just the re-installation you're having problems with? Have you looked at /var/log/vbox-install.log? What does it say in vbox-install.log? Sep 2, 2016 at 12:49
  • The other thing you could try is installing using: sudo apt install virtualbox-5.1 Sep 2, 2016 at 12:52

All you need to do is issue:

sudo dpkg-reconfigure virtualbox-5.1

Once you do you will get the setup message that it needs to create a system users group. Just hit enter and it will drop back to terminal and you will see a one liner stating the group already exists and a blank line below that. The module rebuild process is hidden behind this blank line. Wait until an interactive prompt returns (only takes a minute or 2). Then you will be good to go. No need to re-install the program man that's overkill.

Also for other Host Linux OSes (or if you like to see more info on Ubuntu) the following command is all you need on any Linux host:

 /sbin/rcvboxdrv setup

This works the same as the older /etc/init.d/vboxdrv setup they have just changed the name.


None of the above worked when it tried the various suggested remedies. However, the problem was fixed by upgrading Ubuntu 16.04 to Ubuntu 18.04 using the software updater.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .