0

I need to install this library so I can install another program to monitor data usage, but I can't install the library because nowhere I find the download tells me how to install it.

I already downloaded c make but its just so complicated and I need help.

I've tried in terminal Make C make and install ./configure and a really long command that I found on one site but nothing worked.

I need the dev version of the library

EDIT: I'm installing bitbudget-1.1

5
  • 2
    which program you were trying to install? – Anwar Sep 2 '16 at 5:03
  • i am installing bit budget – Ubuntu N00B Sep 2 '16 at 5:09
  • libdbusmenu-qt5 should be available in the default repository of Ubuntu 16.04. apt-cache policy libdbusmenu-qt5 lists version 0.9.3+16.04.20160218-0ubuntu1. Regarding the dev version - it should be libdbusmenu-qt5-dev then i guess - as well available via the default repositories. – dufte Sep 2 '16 at 6:25
  • @dufte so its preinstalled is that what you mean? – Ubuntu N00B Sep 2 '16 at 6:31
  • No, but it is available to be installed using apt – dufte Sep 2 '16 at 6:36
2

The library you are looking for can be installed like this:

sudo apt install libdbusmenu-qt-dev

or specifically qt5 version sudo apt install libdbusmenu-qt5-dev (either one works)

However, You may not be able to use the BitBudget binary once you have built it. I can build it successfully, but it won't run on my system, as it hasn't been updated for so long.

Assuming you downloaded the bitbudget tarball from Launchpad here to the Downloads directory, do:

sudo apt install g++ libdbusmenu-qt-dev
cd Downloads
tar xf bitbud*
cd bitbud*
qmake BitBudget.pro
make
qmake bitbudget-daemon.pro
make

Check that the binary works: ./BitBudget (for me it segfaults). If it fails for you too, then you can just delete the whole directory.

If it works, then install to the /opt directory

sudo mkdir /opt/BitBudget
sudo cp BitBudget /opt/BitBudget
sudo cp bitbudget-daemon /opt/BitBudget/
sudo cp bitbudget.desktop /usr/share/applications/
sudo cp data/bitbudget.svg /usr/share/pixmaps/

This includes installing a desktop launcher to run the program so you should be able to run it just by clicking the icon, if it works on your system.

2
  • this helped alot thankyou it worked – Ubuntu N00B Sep 2 '16 at 7:54
  • that's awesome! I'm really glad it worked for you :) @UbuntuN00B – Zanna Sep 2 '16 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.