I'm running ubuntu 11.04. I'm trying to install the latest "eclipse for java developers" IDE (version Indigo 3.7.1).

I have downloaded and extracted it. I attempt to run it by changing to the extracted folder and executing


This produces the following errors in the terminal:

> /usr/lib/gio/modules/libgiobamf.so: wrong ELF class: ELFCLASS64 Failed
> to load module: /usr/lib/gio/modules/libgiobamf.so
> /usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
> Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

And then a dialog opens with this error message:

JVM terminated. Exit code=13 /usr/bin/java
-jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-os linux
-ws gtk
-arch x86
-launcher /opt/eclipse/eclipse
-name Eclipse
--launcher.library /opt/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505/eclipse_1407.so
-startup /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-exitdata 2f80031
-product org.eclipse.epp.package.java.product
-vm /usr/bin/java
-jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar

I'd appreciate any help / insight.


I should mention that I'm running 32 bit ubuntu and I'm trying to install 32 bit eclipse.

Update #2

Oops - I just realized that I'm running 64 bit ubuntu, not 32 bit ubuntu.

  • :D so I was right – binW Nov 23 '11 at 11:31
  • Ah, just saw "or vice versa" at the end of your first sentence. Thanks! – James Nov 23 '11 at 11:34

I believe this is because you are trying to run 64 bit eclipse on 32 bit system or vice versa. Make sure you are downloading the right version of Eclipse for your machine i.e if you are running 32 bit Ubuntu then download Eclipse for 32 bit Linux.

The ELF error is indicating that the 32 bit application is trying to load a 64-bit shared library. It appears as somehow a 64 bit library got installed into /usr/lib. There are two open bugs for the above mentioned libraries:


Eclipse is not a 100% pure Java application. All the GUI-stuff happens in native code that must be supported by the underlying operating system, and your errors come from using a different version than the one you should use.

Download the correct version and try again.

If you do not need Eclipse 3.7 but can live just fine with a slightly older version of Eclipse, it is available as a package inside Ubuntu. For 11.10 it is Eclipse 3.6, I do not know about 11.04. I would suggest just finding it and installing it, or just run

sudo apt-get install eclipse
  • In 11.04 and older eclipse in repo's is Galileo(3.5), in 11.10 it's Indigo(3.7, the latest). – foxy Nov 23 '11 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.