1

I'm running Kubuntu 16.04 and the stock file browser (Dolphin) fails to render any video thumbnail previews at all locally or on a samba share. Edit: Sliding the icon size bar to 96+ pixels causes the thumbnails to render locally - still no remote share rendering though.

I've installed Nautilus and video thumbnail previews work locally but not remotely. Supposedly there is a setting to enable thumbnails from all sources (defaulted to only work on local for some reason). Except on Kubuntu, there is no way to access the preferences menu. I get that if I was running GNOME I'd be able to access it via the top bar menu but it's effectively broken in Kubuntu and you get nothing. Alt button does nothing either.

I then installed Nemo and thought I finally almost had it when it worked locally and there was an accessible preferences menu (holy crap I've taken that for granted) and even after specifying to generate thumbnails always (local/remote) and even after specifying to do it for files up to 100mb when the biggest videos are like 4mb, it still does not work! Even rebooted.

I've installed every '*thumb*' package from synaptic I could find that seemed relevant.

I'm at my whits end on this one. What am I missing?

3

To get them working in Dolphin:

sudo apt install ffmpegthumbs

due to a bug in KDE5 you might have to

sudo ln -s /usr/lib/x86_64-linux-gnu/plugins/* /usr/lib/x86_64-linux-gnu/qt5/plugins/

Then open Dolphin

Control --> Configure Dolphin --> General --> Previews

Enable previews for Video Files and enter into the

Skip previews for remote Files above:

a sufficiently high value

Checked on Ubuntu 16.04 with KDE 5.6

4
  • I did already do that. Interestingly though I did discover one new thing. I can get the local thumbnails to work in Dolphin by changing the pixel resolution on the lower right to 96+. Anything below 96 pixels does not render thumbnails. At least theres some consistency now.
    – Enigma
    Sep 2 '16 at 20:26
  • @Enigma Have you tried creating the symbolic links as in my improved answer. It helped me get pdf previews working....
    – Bruni
    Sep 19 '16 at 8:33
  • Ah.. very nice - works perfectly for me for video thumbnails and all.
    – Enigma
    Sep 21 '16 at 3:28
  • is there a way to achieve this without root permissions? I have tried to have ~/.local/lib in place of /usr/lib when relevant, but with no luck.
    – norok2
    May 9 '17 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.