I'm using ubuntu 16.04 LTS.

I've downloaded the latest krita appimage (http://files.kde.org/krita/3/linux/krita-3.0-x86_64.appimage)

I want to be able to open Krita files (with the extension ".kra", mime-type "application/x-krita") with this appimage, by double-clicking the file icon.

How do I do this?

I have tried moving the appimage to /usr/share/applications, I've tried adding a desktop file /usr/share/applications/krita.desktop with the following contents:

[Desktop Entry]
Name=Krita
Exec=/usr/share/applications/krita-3.0-x86_64.appimage %F
Type=Application
MimeType=application/x-krita

I've made sure both files have the same permissions as other files in the same directory.

Krita does not appear under "Open With Other Application…"

  • 3.0.1 doesn't =( would like to get this working too. – 43Tesseracts Sep 8 '16 at 4:43
up vote 6 down vote accepted

Got this working on Mint 18.1 Cinnamon.

The .appimage of Krita 3.1.2 didn't add any file associations, so I created a file named krita.desktop, and put the following inside:

[Desktop Entry]
Encoding=UTF-8
Name=Krita
Comment=Krita, An open source painting and drawing application.
Exec=[path to .appimage] %F
Type=Application
Icon=[path to icon]
Categories=Graphics; 
MimeType=image/krita;

I made that file executable, then copied it to /usr/share/applications.

Next I opened ~/.config/mimeapps.list, and appended:

image/krita=krita.desktop;

under the section [Added Associations]

Finally I right clicked a .kra file and chose Krita as the default app under Open With.

Hope that helps someone out.

  • 1
    I played around with this a little, and ended up with both mime-types ("image/krita" and "application/x-krita") in both files (separate by the ; in krita.desktop, on separate lines in mimeapps.list), but it's working for me now, thanks. – Peter Chaplin Jun 9 '17 at 14:52

The next version of the Krita AppImage will come with desktop integration which should do this for you automatically.

You can try an alpha build: https://krita.org/en/item/krita-3-0-1-alpha-builds/

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.