0

I click install without understand it all on the "1404_HWE_EOL" update then my ubuntu 14.04 update some parts from wily to xenial then I lost all support of AMD video drivers fglrx, and the performance now sucks as my APU depends on AMD driver to get the best performance for CPU/GPU...

I really thought that the missing support was only on 16.04 so any update of 14.04 was not going to affect me but this did...

After the update it gives me a no boot system that I fix after removing fglrx...

I wanna to go back to "Full wily video support" because my system run so much better, I know I can just reinstall the OS then not do any updates from Software updates, and use the terminal apt-get update/upgrade...

But I don't have much time and no high speed internet so I need to make arrangements to have time and in a place with high speed internet just to reinstall the OS + all the things I need that come from the web...

So I have the list of the crap xenial that was installed, can I safe remove it an go back to wily video support?

This is the Log after the 1404_HWE_EOL

install:

xserver-xorg-video-mach64-lts-xenial:amd64
xserver-xorg-video-all-lts-xenial:amd64 
xserver-xorg-video-amdgpu-lts-xenial:amd64
linux-signed-generic-lts-xenial:amd64
xserver-xorg-video-cirrus-lts-xenial:amd64 
xserver-xorg-video-radeon-lts-xenial:amd64 
xserver-xorg-video-mga-lts-xenial:amd64 
xserver-xorg-video-trident-lts-xenial:amd64 
xserver-xorg-video-fbdev-lts-xenial:amd64 
xserver-xorg-video-tdfx-lts-xenial:amd64 
libllvm3.4:amd64 
libllvm3.4:i386 
libglapi-mesa-lts-xenial:amd64 
libglapi-mesa-lts-xenial:i386
xserver-xorg-video-ati-lts-xenial:amd64
libwayland-egl1-mesa-lts-xenial:amd64 
xserver-xorg-input-all-lts-xenial:amd64 
xserver-xorg-video-neomagic-lts-xenial:amd64 
xserver-xorg-video-savage-lts-xenial:amd64 
libegl1-mesa-lts-xenial:amd64 
xserver-xorg-input-vmmouse-lts-xenial:amd64 
xserver-xorg-input-evdev-lts-xenial:amd64 
linux-signed-image-4.4.0-36-generic:amd64 
libgles2-mesa-lts-xenial:amd64 
xserver-xorg-video-vesa-lts-xenial:amd64 
linux-signed-image-generic-lts-xenial:amd64 
xserver-xorg-video-siliconmotion-lts-xenial:amd64 
libxatracker2-lts-xenial:amd64 
xserver-xorg-input-wacom-lts-xenial:amd64 
xserver-xorg-video-nouveau-lts-xenial:amd64 
xserver-xorg-video-openchrome-lts-xenial:amd64 
xserver-xorg-video-qxl-lts-xenial:amd64 
libgbm1-lts-xenial:amd64 
xserver-xorg-video-intel-lts-xenial:amd64
xserver-xorg-video-sisusb-lts-xenial:amd64 
libgl1-mesa-dri-lts-xenial:amd64
libgl1-mesa-dri-lts-xenial:i386 
libgl1-mesa-glx-lts-xenial:amd64 
libgl1-mesa-glx-lts-xenial:i386 
xserver-xorg-video-vmware-lts-xenial:amd64 
xserver-xorg-core-lts-xenial:amd64 
xserver-xorg-video-r128-lts-xenial:amd64 
libgles1-mesa-lts-xenial:amd64 
xserver-xorg-lts-xenial:amd64 
xserver-xorg-input-synaptics-lts-xenial:amd64 
libllvm3.8v4:amd64

...

Remove: 
xserver-xorg-video-neomagic-lts-wily:amd64 
xserver-xorg-input-wacom-lts-wily:amd64 
xserver-xorg-video-radeon-lts-wily:amd64 
xserver-xorg-video-nouveau-lts-wily:amd64 
xserver-xorg-video-vmware-lts-wily:amd64 
xserver-xorg-core-lts-wily:amd64 
xserver-xorg-lts-wily:amd64 
xserver-xorg-input-vmmouse-lts-wily:amd64 
xserver-xorg-video-openchrome-lts-wily:amd64 
libgbm1-lts-wily:amd64 
libgl1-mesa-glx-lts-wily:amd64 
libgl1-mesa-glx-lts-wily:i386
libglapi-mesa-lts-wily:amd64 
libglapi-mesa-lts-wily:i386 
xserver-xorg-video-savage-lts-wily:amd64 
xserver-xorg-video-sisusb-lts-wily:amd64 
xserver-xorg-video-trident-lts-wily:amd64 
libgl1-mesa-dri-lts-wily:amd64 
libgl1-mesa-dri-lts-wily:i386 
xserver-xorg-video-ati-lts-wily:amd64 
xserver-xorg-video-mach64-lts-wily:amd64 
xserver-xorg-video-tdfx-lts-wily:amd64 
xserver-xorg-video-r128-lts-wily:amd64 
xserver-xorg-input-evdev-lts-wily:amd64
xserver-xorg-input-all-lts-wily:amd64 
xserver-xorg-video-siliconmotion-lts-wily:amd64 
libxatracker2-lts-wily:amd64 
xserver-xorg-input-synaptics-lts-wily:amd64
libegl1-mesa-lts-wily:amd64 
xserver-xorg-video-mga-lts-wily:amd64
xserver-xorg-video-qxl-lts-wily:amd64 
libgles2-mesa-lts-wily:amd64 
xserver-xorg-video-all-lts-wily:amd64 
xserver-xorg-input-mouse-lts-wily:amd64
libwayland-egl1-mesa-lts-wily:amd64 
xserver-xorg-video-cirrus-lts-wily:amd64 
xserver-xorg-video-fbdev-lts-wily:amd64 
xserver-xorg-video-vesa-lts-wily:amd64

I try to remove some and I can't or I can but can install the old and the system don't works after...

some error like this on the terminal

requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Any help is appreciated, thanks....

  • 3
  • that is for utopic (14.04.3), my system is wily 14.04.5... there is a fix for that? I can't find... – Felipe L BHB27 Sep 1 '16 at 23:45
  • Utopic is 14.10, so I'm not sure where you got that idea. 14.04.3 is just a lower point release of 14.04. – TheWanderer Sep 1 '16 at 23:57
  • @FelipeLBHB27 erm, I think you misunderstand the versioning. Utopic is 14.10, Wily is 15.10, both are EOL. Where are yo ugetting Utopic and Wily form here? – Thomas Ward Sep 1 '16 at 23:59
  • @ThomasWard and Zacharee1 , I know I may not fully understand version tags, but the link point me do downgrade xorg to " xserver-xorg-lts-utopic " there utopic but you guys can see on my logs that I was running " xserver-xorg-lts-wily" and for my understand wily is newer then utopic so I prefer to reaming on the one I believed will be most stable, newer but of course with fglrx support... I fix the problem will add a Answer... thanks – Felipe L BHB27 Sep 2 '16 at 4:09
1

So the Fix here was simple after @Zacharee1 commented a link which I managed to adapt to my use...

sudo apt-get install xserver-xorg-lts-wily libgles1-mesa-lts-wily libgl1-mesa-glx-lts-wily libgl1-mesa-glx-lts-wily libglapi-mesa-lts-wily libegl1-mesa-lts-wily libwayland-egl1-mesa-lts-wily

After rebooting all is good, then I reinstall fglrx and everything regards that this is running okay.

But of course some things are still broken, for example wine did not work after the process. If I try to install or remove it I get:

sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
 wine : Depends: wine1.6 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Then I fix it with

 sudo sh -c "apt-get update;apt-get dist-upgrade;apt-get autoremove;apt-get autoclean"

Now I can install wine just fine, and no more errors regarding apt-get.

Still need to continue to look around and will look back if something else fails.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.