First, I updated to the Anniversary Edition of Windows (yay for linux subsystem!). After that I resized my Windows partition and installed Ubuntu. Later, I found that I would have to revert to the version of Windows before the Anniversary Update do to a glitch, so I used Windows' restore functionality. It worked, but now the boot manager doesn't appear!

Any help would be very much appreciated!

Here is a screenshot of Disk Management in Windows, if it helps:

Here is a screenshot of Disk Management in Windows, if it helps

2 Answers 2


That is because your boot manager (chances are that it is GRUB2) went south from the MBR.

You need to boot from your Ubuntu installer in "live CD" (try without installing) mode, then open a terminal, get a root shell, and chroot yourself in your installation before you can run grub-install.

For that, mount your hard drive (presumably /dev/sda2 or /dev/sda3) somewhere (for the sake of the least resistance, let it be straight /mnt).

After that, mount the necessary file systems:

# mount -o bind /proc /mnt/proc

# mount -t sysfs /sys /mnt/sys

# mount -t proc /proc /mnt/proc

Finally chroot into your installation:

# chroot /mnt /bin/bash

Now you need to reinstall grub with the same parameters:

# grub-install /dev/sda

Mind that you need to specify the device itself, not the partition (e.g. no /dev/sda3 but /dev/sda) when installing grub to MBR.

Now you are done, you can reboot and boot Ubuntu.

  • Yeah, it was Grub2. I ended up following this tutorial to boot into my Ubuntu Live USB after deleting my linux partitions. Then I just reinstalled Ubuntu normally. After that everything worked. If I saw your answer before I would definitely have done that though, so thanks for the though! Sep 3, 2016 at 15:15

I deleted the Linux partitions, thinking I would just reinstall it. But when I rebooted my computer, I was met with the Grub CLI. What I think happened was Grub's configuration file was stored somewhere in linux partitions I deleted, and so it just booted up command line style.

What I ended up doing was running the command

chainloader (hd0,1)/efi/Microsoft/Boot/bootmgfw.efi

followed by


This booted into Windows. I then followed this tutorial (I had to modify the paths they give) to boot into an Ubuntu Live USB and from there I reinstalled Ubuntu. After that, the configuration file was added back and everything was rosy!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .