2

I tried using few different distros on this laptop in last few years. I really like linux and want to use it in every day use but I have all sorts of problems on my laptop lenovo g500. Yesterday I finally decided to install it and make it work. For now I can't figure out how to make my hibrid gpu's switchable and I can't change my mac without breaking wifi totally (wifi just refuses to work even if I take it down via ifconfig, or even stopping the network-manager service, change mac, restart, still won't work). So I am hoping people here can help me.


First off, making hybrid GPUs switchable. I have integrated INTEL and discrete AMD gpu.

I followed HybridGraphics guide but when I try to echo any parameter to

/sys/kernel/debug/vgaswitcheroo/switch

for example

sudo echo IGD > /sys/kernel/debug/vgaswitcheroo/switch

Whatever parameter I use IGD/DIS/ON/OFF etc. Nothing happens.


Here's some info (command-result):

lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 3rd Gen Core processor DRAM Controller [8086:0154] (rev 09)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port [8086:0151] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0156] (rev 09)
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4)
00:1c.1 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 [8086:1e12] (rev c4)
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation HM76 Express Chipset LPC Controller [8086:1e59] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e03] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)
01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Sun PRO [Radeon HD 8570A/8570M] [1002:6663] (rev ff)
02:00.0 Ethernet controller [0200]: Qualcomm Atheros QCA8172 Fast Ethernet [1969:10a0] (rev 10)
03:00.0 Network controller [0280]: Broadcom Limited BCM43142 802.11b/g/n [14e4:4365] (rev 01)

sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +52.0°C  (crit = +127.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1:       +511.0°C  (crit = +120.0°C, hyst = +90.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +53.0°C  (high = +72.0°C, crit = +90.0°C)
Core 0:         +48.0°C  (high = +72.0°C, crit = +90.0°C)
Core 1:         +51.0°C  (high = +72.0°C, crit = +90.0°C)

sudo cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Off:0000:01:00.0

NOTE: "DIS" gpu was DynOff until I followed this guide Hello, I tried using few different distros on this laptop in last few years. I really like linux and want to use it in every day use but I have all sorts of problems on my laptop lenovo g500. Yesterday I finally decided to install it and make it work. For now I can't figure out how to make my hibrid gpu's switchable and I can't change my mac without breaking wifi totally (wifi just refuses to work even if I take it down via ifconfig, or even stopping the network-manager service, change mac, restart, still won't work). So I am hoping people here can help me.


First off, making hybrid GPUs switchable. I have integrated INTEL and discrete AMD gpu.

I followed HybridGraphics guide but when I try to echo any parameter to

/sys/kernel/debug/vgaswitcheroo/switch

for example

sudo echo IGD > /sys/kernel/debug/vgaswitcheroo/switch

Whatever parameter I use IGD/DIS/ON/OFF etc. Nothing happens.


Here's some info (command-result):

lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 3rd Gen Core processor DRAM Controller [8086:0154] (rev 09)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port [8086:0151] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0156] (rev 09)
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4)
00:1c.1 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 [8086:1e12] (rev c4)
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation HM76 Express Chipset LPC Controller [8086:1e59] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e03] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)
01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Sun PRO [Radeon HD 8570A/8570M] [1002:6663] (rev ff)
02:00.0 Ethernet controller [0200]: Qualcomm Atheros QCA8172 Fast Ethernet [1969:10a0] (rev 10)
03:00.0 Network controller [0280]: Broadcom Limited BCM43142 802.11b/g/n [14e4:4365] (rev 01)

sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +52.0°C  (crit = +127.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1:       +511.0°C  (crit = +120.0°C, hyst = +90.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +53.0°C  (high = +72.0°C, crit = +90.0°C)
Core 0:         +48.0°C  (high = +72.0°C, crit = +90.0°C)
Core 1:         +51.0°C  (high = +72.0°C, crit = +90.0°C)

sudo cat /sys/kernel/debug/vgaswitcheroo/switch

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Off:0000:01:00.0

NOTE: "DIS" gpu was DynOff until I followed this guide


I am thinking that something might be wrong or that there simply is no driver for my amd gpu. But last year I think, I tried installing fglrx driver package and my ubuntu just keeps crashing then. Same with Fedora as well. Also when I check in "additional drivers" in system settings I am not getting any options for my amd card.

I have switchable graphics enabled in BIOS. I am using 16.04 ubuntu

  • Are you using 16.04? – TheWanderer Sep 1 '16 at 17:56
  • yes I am using LTS 16.04 – Luka Milosevic Sep 1 '16 at 17:58
  • 1
    Possible duplicate of Ubuntu 16.04 and AMD graphics – TheWanderer Sep 1 '16 at 17:59
  • I don't think so. That user has a problem with AMD graphics only. I need to make switchable graphics work. – Luka Milosevic Sep 1 '16 at 18:01
  • That is a Q&A by me explaining the whole situation of AMD graphics in 16.04. It doesn't matter if you have switchable or not. That answer will apply. – TheWanderer Sep 1 '16 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.