0

Ok i know this has been asked on the forum more than ones and i have read and tried the two guides i've found plus one on Pen-Drive. I would also rather have commented on the posts i found but i can't comment till i have 50 Rep points but i can edit the original post i'm trying to comment on, makes no sense but cool that is how the forum is run.

The three guides i've found is:

How to make a persistent live Ubuntu USB with more than 4GB

Trouble With Persistence After Making a USB Live Thumb Drive Using Pendrivelinux

Create a Larger than 4GB Casper Partition

The problem i'm having is non of these seem to work, i've tried them with Ubuntu and Kubuntu 16, 12 and 11 since the one comment on the 1st link also said he can't get it working on anything over 14.

Problem i have is i either end up with the Illegal OpCode Red screen of death, the install not detecting persistence at all and asking to try or install linux each time it boots, i've had the can't mount /dev/sda2 on /cow, or i get a black screen saying initramfs.

I have tried almost all the fixes i could find the comment of topics based on the errors.

I have tried Universal-USB-Installer, live-usb-installer, linuxlive usb creator, a month or so back a program called rufus or something.

All the guides and apps work until it gets to the part where i delete the casper-rw file

I even came across this post: Unable to boot Ubuntu Live USB Flash Drive with casper-rw persistent partition tried all the steps the user gave in the comments (araghuteja) and after i delete the casper-rw file i get the back screen initramfs again.

I'm currently trying the comment by Yu Jia Cheong but i'm stuck on step 3 and on of her comment:

3) Boot up with the new USB. Open /usr/share/initramfs-tools/scripts/casper with root to edit (sudo). Change the function setup_unionfs() to the following : https://launchpadlibrarian.net/258626969/casper%20function.txt

4) sudo update-initramfs -u (Had to uninstall cryptsetup to do this)

5) Copy the generated initrd.img file from /boot to another location.

6) From another OS, delete the casper-rw file in the USB. Copy the initrd.img back to the live partition and change menu item to use the newly built initrd.img.

The next time you boot up from USB, it should now bootup from the casper-rw partition.

This worked for me for 16.04 after a long frustrating time searching for the solution!

I don't know if i'm just too tired of reading at this point and my eyes are reading what i want to read and not what is written but the file mentioned looks the same to me as the one the link point to.

And if i run step 4 after i close the file i get a error message...

Does anybody have any idea where I'm messing this up?

Thanks for the Time...

1

Persistent partitions have not been working with Ubuntu, syslinux type installs since 14.04.

These include Rufus, UNetbootin, Universal, Startup Disk Creator, etc.

Persistent partitions do work with grub2 type installs and can automatically be created with mkusb and dus, both created by Sudodus.

Latest info on these installers can be found at:

https://help.ubuntu.com/community/mkusb

1

Update Aug/2017

Syslinux started adding support for NTFS with version 4.06 but did not offer full support until version 6.03.

UNetbootin - 655 uses Syslinux 4.03 and is still limited to 4GB persistence files per FAT32.

MultiBootUSB - 8.8 uses Syslinux 4.07 and will install on NTFS, persistence files are not limited to 4GB.

Rufus 2.16 uses Syslinux 6.03 and will install on NTFS, persistence files are not provided but can be added manually and are not limited to 4GB.

YUMI - 2.0.4.9, (MultiBoot USB), uses Syslinux 6.03 and will install on NTFS, persistence files are not limited to 4GB. Like MBUSB 8.8 it can have persistence files for each distro install

0

I think the problem is here:

4) sudo update-initramfs -u (Had to uninstall cryptsetup to do this)

You are doing this with an encrypted system.

-o-

In a standard live system you can simply replace the casper-rw file with a casper-rw partition, and the live system will find it.

  • Boot from another live drive

  • Remove the casper-rw file.

  • Start gparted

  • Shrink the partition, where you have the system (and where you had the casper-rw file).

  • Use the unallocated drive space to create a new partition with an ext file system (ext2, ext3 or ext4).

  • Put the label casper-rw on this new partition.

  • Click the tick to really perform the changes.

  • Reboot (and make sure that there is a boot option 'persistent').

-o-

You can do all this automatically with mkusb, and create a new user with encrypted home afterwards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.