12

I was using workplace switching for a long time and it suddenly stopped working today. Even after a fresh install, (some config left over as I preserved my /home folder).

Super + S still raises to show all work-spaces.

Clicking on a task-bar icon representing a window in another work-space no longer switches to that workspace + window.

Ctrl + Alt + (any direction) no longer works.

Ctrl + Shift - Alt - (any direction) no longer works.

I've verified that those key combos are registering by redundantly re-assigning the shortcut mappings.

25

Did another search today and found this: Can't switch workspaces

The advice to go to Compiz ccsm and activate Desktop Wall fixes the problem immediately.

What a relief !

| improve this answer | |
  • 3
    This didn't work for me. Why are there so many different ways to enable workspaces that all don't work? I wish the Ubuntu team would stop adding stupid fluff to the OS and just focus on making it work properly. – Jake Mar 26 '17 at 22:42
  • 1
    these days im using unity tweak tool-- havent experienced this issue in some time. – Wylie Кулик Mar 27 '17 at 5:02
  • I tried the Unity Tweak Tool on a fresh install just yesterday. Doesn't work either. – Jake Mar 28 '17 at 5:49
  • Even more mysterious: worked for a long time and was still working for another user on same system, having changed nothing. Suddenly stopped working. This fix worked for me. Thanks a bunch! – bytepusher Apr 25 '17 at 22:48
  • Worked for me. I had to install CompizConfig Settings Manager. Annoying this broke in the first place – Robert3452 Mar 10 '18 at 14:16
5

I am experiencing the same problem, so I have filed a bug on launchpad.

| improve this answer | |
1

Try the following.

sudo apt-get install dconf-tools

dconf reset -f /org/compiz/

This worked for me

| improve this answer | |
0

It didn't work for me... but this one worked in my case See section Desktop Size
Check if your Desktop Size ain't set to 1x1.
Compiz > General > "General settings" > Desktop size (I'd to expand to see that one) enter image description here Thanks to LIttle Ancient Forest Kami

| improve this answer | |
0

I had a similar problem: the workspace switcher stopped working out of the blue. Enabling workspace switching using Compiz config settings manager didn't work. There was no visible change.

Installing Unity tweak tool, and enabling workspaces there worked for me.

In Unity Tweak Tool -> Workspace Settings : Set worskapce switcher to ON and select number of workspaces.

| improve this answer | |
-2

I'm using gnome desktop instead of unity in Ubuntu 16.04 and I had to install Compiz Config Settings Manager and its listed under the Applications menu - System Tools - Preferences. Then in Compiz Config Settings Manager, go to the General Options - Desktop Size tab and set your row settings and it should work immediately.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.