I have an Ubuntu 16.04 system and a Win 7 vdi from my previous computer. The first time I installed virtual box it installed I installed extensions and guest additions for the same version. I got everything working in the VM but USB. I tried 2.0 and 3.0, neither change helped. I googled around a bit and found that I need to add my user to vboxusers group. I did that. Now I can see the usb devices in the device list but they aren't installing on my VM. What else might I need to do?

Update 1: I will add that it's not all USB devices as my mouse and keyboard still work but any storage device (4 differently branded thumb drives and 1 external HD) all do not get recognized. Weirder still, at least 2 of these thumb drives and the external drive worked when the VM was on my old machine.

Update 2: I failed to mention that after I tried the vboxusers group addition I updated everything to 5.1 Virtualbox and it still wasn't working.

Update 3: I tried claude's solution and that didn't work.

I suspect my VM is corrupted somehow so I spun up another VM (Windows 10 this time) and everything USB works on that. I've been slowly migrating all of my files and reinstalling apps over on the new VM.

3 Answers 3


In case you did not find the solution yet. I had the same problem with Ubuntu 16.04 as host and XP as guest. None of the known solutions for the problem worked. I found the right trail at the very end of this page : https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1576768 which led me to this article : https://phobosk.wordpress.com/2012/11/11/howto-fix-a-virtualbox-failed-to-access-the-usb-subsystem-error/

In summary, the reason is that the limit for inotify on max_user_watches is to low .

Solved by : First, adding the following lines to /etc/sysctl.conf

fs.inotify.max_user_instances = 256<br />
fs.inotify.max_user_watches = 16384<br />
fs.inotify.max_queued_events = 32768<br />

Then restarting procps for the change to take effect with command :

sudo service procps restart

That did it !


Two places you can enable USB devices.

  1. In your guest OS, go to the Devices menu, then USB. In the list of USB devices present, select the one(s) you want to connect to, and this will place a checkmark in front of that device name. Windows will then install drivers for that device, if it needs to.

  2. In the main Settings for your guest OS (if the guest OS is shutdown) you can select USB, and in the USB device list presented there, any box you checkmark will automatically be connected when the guest OS is started.

Keep in mind, that any USB devices connected to a guest OS, will not be available to the host OS, as long as the VM is running.

If you have more questions, please ask. Cheers, Al

  • Al, thanks for your reply. Unfortunately, neither of these processes helps me. I have the devices checked that I want to be accessible on my Windows machine and they don't get installed. I have the devices set in my USB section while the OS is off. When I turn it on, they aren't installed. Sep 1, 2016 at 12:30
  • Are you saying that some USB devices ARE visible to the guest OS, and some aren't? I think that you said that you tried both USB 2.0 and USB 3.0 ports, yes? You might trying installing Virtualbox 5.1 and see if that fixes the problem. Cheers, Al
    – heynnema
    Sep 1, 2016 at 13:54
  • Al, my apologies, I did install 5.1 after didn't. That's why 5.1 virtualbox is in my question title, I just didn't update my post. Let me do that now. Sep 1, 2016 at 14:04
  • In the Settings for the guest OS, under System, is I/O APIC checked? Cheers, Al ps: please also answer the other two questions that I asked.
    – heynnema
    Sep 1, 2016 at 14:08
  • I/O APIC is checked. My keyboard and Mouse are visible under devices and working, although they are not checked. I have tried both 2.0 and 3.0. Sep 1, 2016 at 14:16

I had this issue on Fedora 26/27 on a Windows 7 host with Virtualbox 5.1/5.2. The problem was with Windows "UpperFilter" USB drivers and Virtualbox (guest OS agnostic; applies to any Linux distro), which was apparently known as early as 7 years ago. If none of the other USB solutions worked, hopefully this does for you. See solution below


  • select device from Devices -> USB -> USB drive
  • nothing happens
  • checking Devices -> USB menu again, the USB drive is not ticked, but says "captured"
  • however, hovering over the USB icon in the bottom right says "no devices"
  • checking VBoxManage.exe list usbhost on the host shows the USB device + "captured"
  • but the VM doesn't see anything
  • trying to add the device again (through Devices -> USB menu) gives a "busy with previous request" error

Solutions from other threads which did not work:

  • successfully installed guest additions (e.g. shared folders work (have myself to the vboxsf group))
  • no vboxusers group, creating the group myself (as recommended by some threads) and adding myself didn't do anything
  • tried using USB filters (blank filter and device filter)
  • installed the extensions pack, tried default (1.0), 2.0, and 3.0 USB in machine settings
  • tried all 4 combinations of USB 3.0 and 2.0 devices with 3.0 and 2.0 ports (Virtualbox supports USB 3.0 as of version 5 IIRC)


Found the solution in comments 21 and 26 of this virtualbox bug report: https://www.virtualbox.org/ticket/3033#comment:21

There are several comments in the community that VirtualBox USB support doesn't work with upper filter drivers installed on Windows hosts.

  • kepler2 7 years ago

Paraphrasing solution from nayasis from https://forums.virtualbox.org/viewtopic.php?f=6&t=39104 :

  1. Edit the registry: open regedit.exe (search for it in start menu), and find HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000} (click on it)
  2. Delete entry UpperFilters on the right
  3. Possibly rerun the Virtualbox drivers manually: go to C:\Program Files\Oracle\VirtualBox\drivers\USB\filter, right click VboxUSBMon.inf and "Install" (I did this to be safe, but I'm not sure if it's necessary; it seems some people only needed to delete the registry entry)
    • This Windows thread suggests also deleting LowerFilters entry if it exists too. I did not have LowerFilters
  4. Shut down your VM, remove all filters
  5. Reboot
  6. Plug in your USB, start your VM, and hopefully you can add the USB now. Filters, AFAIK, are only necessary for automatically adding USB devices. It shouldn't affect whether you can successfully add a device or not

Was incredibly frustrating finding all the other solutions which were not the issue here. Hope this helps people in the future!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .