1

I'd try to be as short and precise as I can, so here goes all the facts:

  1. Im running 16.10 (this issue has followed me from 14.04,on the same laptop, and it made me go back to windowsh, so this bad/annoying of a bug it was)
  2. My laptop is a Sony Vaio VPCEG44FX with upgraded ram (16GB and a 1TB samsung SSD, Nvidia Geforce 440m and a i7 processor(2.45ghz) It is a small beast 5 years old and a warrior I love. (there is nothing wrong on the hardware side I can ASSURE)
  3. I'm using NVIDIA bINARY 367.35 from Nvidia repo.
  4. Besides the issue I will now try and describe, there is nothing else that bugs me off Ubuntu, my laptop runs cool now (It was alway burning in windows)

So to the Issue:

Every single time (since 14.04) as the computer boots up, it show the VAIO splash screen, the a Nvidia splash screen (that dims after it is shown) then a short TTY input (something like username-vaioTTY:password) and then I hear the login sound. But the screen is totally black at this point.

I usually proceed to login, but here goes the weird part; usually, and as I've read, you should just up the brightness using FN hotkeys right? well, I cannot do that. I cannot turn up or down the volume, nor turn the brightness up or down. I have to connect an external display, and then the FN key to switch between LCD/External/clone or extend (FN+F7 here) until the external monitor asks for an input (This means Iǘe switched to LCD only mode) and at this point my brightness hotkeys start working.

This very issue made me abandon ubuntu at 14.04, when I started using NVIDIA drivers, so I can guess it's related to them.

Well, fast forward some time and I decided to give Ubuntu another go. installed 16.04 it boots up perfect the first time, then came the dreaded bug. I noticed it just happened after I connected a external display for the first time (first 10 boots approx were fine, as I did not had the need yet for using the other screen) After I connected the screen for the first time, the consequent reboots issued that same bug I described.

I just upgraded to 16.10 Still fighting this. I've tried using legacy drivers, Noveau drivers are out of question for me. (I use tensorflow and other cuda software, needed for my workflow.)

So here I am, a googler and lurker and copypaster asking for your mercy! I usually troubleshoot myself as almost any issue has been asked, but I cannot put my finger on this specific problem.

If any one here would be so kind to pint me in the right direction I'd be oh-so grateful.

BTW, I do not want set brightness scripts, I want my beatiful login screen to show up!! I do not want a semi broken OS.

  • I would just ditch your Nvidia GeForce 440M for awhile and use the built in Intel HD3000 graphics. It is more than fast enough for web browsing, movie watching, etc. After you get your system working the way you like then start activating various Nvidia drivers until you find the right combination. I've had Nvida 650M for 2 years and still haven't ventured to setup drivers under Ubuntu yet. Intel HD4000 GPU is more than fast enoug in Ubuntu and system load is minimal (17%) with TV shows Youtube and browsing active at same time on 2 screens. Just a comment, not an answer. – WinEunuuchs2Unix Sep 1 '16 at 0:03
  • Yup, well it came to me as a surprise that this laptop has an intel integrated card! I appreciate your comment, and have solved my issue (temporarily) out of luck I guess. I turned off the laptop with the external monitor still plugged in and powered on. This morning I booted it up (had previously turned off the monitor) and the NVIDIA logo at boot was well-lit, and the login screen was as well. The brightness hotkeys are not working, but the computer is. As an update, I had restarted the computer and it seems to be a rather "stable" fix. – WastedWeasel Sep 7 '16 at 0:07
  • And another update, I got my brightness hotkeys working! I'll self answer my question right now. Btw, @WinEunuuchs2Unix, I game a lot on my laptop, otherwise I would have gone with your suggestion, It's pretty cool that now I know I have a backup graphics card! Thanks a lot mate. – WastedWeasel Sep 7 '16 at 0:10
  • That's great. Should I post my comment as an answer that you mark as solved? Or would you like to post an answer and mark it solved? It's best not to leave unanswered questions on the site. – WinEunuuchs2Unix Sep 7 '16 at 0:13
  • @WinEunuuchs2Unix, I just posted an answer as suggested. Though your comment would be a great answer for anyone who does not want to use graphics-intensive stuff. – WastedWeasel Sep 7 '16 at 0:40
1

Well, in the comments I stated that I had a semi-workaround out of luck, but now, out of digging around I had come to a complete answer to my problem and I would like to share.

This problem has something to do with backlight control. Hotkeys not working may seem as a keyboard layout issue or something, but I found out that it has nothing to do with the keyboard but a lot to do with ACPI settings and power management.

First of all, this answer is specific to my laptop brand and model, but I infer it could be used for any laptop with this specific error (Brightness hotkeys fn+F5 and +F6, plus stuck at 0% brightness at login)

On a terminal run the following: ls /sys/class/backlight/

The output of this is important (upper-lowercase sensitive, so note this down.)

Mine came out as "sony" minus quotes.

Then sudo gedit /etc/default/grub

On my GRUB file this was the 12th line, I added the acpi_backlight=(output of first command), to look like this:

GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi_backlight=sony"

Then close gedit, go to terminal and run

sudo update-grub

As for the power management part of the answer, you have to uncheck "Dim screen to save power" on Brightness and lock. Hotkeys won't work for me if it is enabled.

Reboot, enjoy working brightness hotkeys, and don't forget to uninstall/remove any brightness/hotkey package you may had installed trying to solve this issue.

  • Click the edit option under your answer and you can change the answer instead of putting a comment underneath it. – WinEunuuchs2Unix Sep 7 '16 at 0:43
  • Done... I think I've been away from online communities so long that I forgot basic netiquette. -My bad. – WastedWeasel Sep 7 '16 at 1:44
  • Naa nothing to do with etiquette. It's the learning curve of buttons, options, etc. we all go through. I'm new here too, about 3 weeks I think. – WinEunuuchs2Unix Sep 7 '16 at 1:46
0

If I can do it, anyone can. I use Ubuntu but I'm not into code and stuff. I had no problem for over a year on my Samsung laptop but every time of late during startup the screen was dim 80% of the time. So after 3 start ups with a Dim screen in a row I ended up looking here. I read the bit about the Fn keys. So I hit Fn - F3 which is brighter but it was already at full brightness even with a dim screen. So for some illogical reason I hit the Fn - F2 key for dimmer and instantly my screen lit up to full brightness and started to dim back from there. So I hit Fn- F3 for brighter again and got back to full brightness. I may have to do this every start up but at least I can solve the problem till someone sorts it out in an upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.