9

I've tried everyway to install drivers for NVIDIA and get it working but my laptop still insist on using Intel Haswell integrated GPU.

Here's a what I've tried so far:

First I've tried to install latest drivers from graphics-driers PPA:

sudo apt-add-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-367 

I was hoping that it could get my graphics card to work but it didn't.

Then I downloaded .run file from offical nVidia website but this installer gives me "The distribution-provided pre-install script failed!" error. Still don't know why it gives me such error.

Last thing I tried was after installing nvidia-367:

sudo apt-get install nvidia-prime
sudo prime-select nvidia
reboot

As you can guess, it didn't work either. sudo lshw -C display command gives me following output:

  *-display               
       description: VGA compatible controller
       product: Haswell-ULT Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 0b
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:43 memory:b5000000-b53fffff memory:c0000000-cfffffff ioport:6000(size=64)
  *-display UNCLAIMED
       description: 3D controller
       product: GM108M [GeForce 840M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:0a:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:b3000000-b3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:3000(size=128)

I'm using Ubuntu 16.04 and my graphics card is nVidia GT 840M

  • You probably need to disable Secure Boot in BIOS. – Pilot6 Aug 31 '16 at 20:53
  • OMFG, thanks man it worked like a magic. If I was in the same country with you I'd make a car ride in this very night to your home and hug till you poop. Thanks again! (not gay) – emreaydin149 Aug 31 '16 at 21:10
5

Secure Boot does not let the nvidia module load.

Disable Secure boot in BIOS and it should be solved.

You can see this question for more information.

| improve this answer | |
  • 17
    That didn't solve it for me unfortunately. Already have it disabled but still have it unclaimed. – Zelphir Kaltstahl Apr 11 '17 at 23:04
  • Do you mind adding this comment in this answer? – BeastOfCaerbannog Nov 20 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.