so I'm trying to install ubuntu 16.04 LTS on my Lenovo Thinkpad Yoga(20C0006DMS). I don't want windows so I just tried to install ubuntu and chose "erase disk". The installation went fine and I connected to our wifi etc and it told me to restart my computer.

But when I start my computer it won't boot. I've tried to fix the grub-install by the "try ubuntu" option and had to force it because it said something about blocklists.

I tried to disable secure boot/change to legacy boot but it still won't work.

I'm trying to install from a bootable-USB which I used rufus to create.

If I try to take my usb out it gives me 2 choices; to boot from my SSD or from windows boot manager. None of them works.

What am I doing wrong?? :(

Intel Core i5-4210U, 256GB SDSD, 8GB RAM 1600MHz

edit, also i don't know how to quote - this is what happens when i do "sudo fdisk -l" in the terminal right after i installed ubuntu.

Disk /dev/sda: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 996829B9-60D6-40CE-AC51-265CE46289DE

Device         Start       End   Sectors   Size Type
/dev/sda1       2048   1050623   1048576   512M EFI System
/dev/sda2    1050624 483522559 482471936 230.1G Linux filesystem
/dev/sda3  483522560 500117503  16594944   7.9G Linux swap

Disk /dev/sdb: 3.8 GiB, 4023386112 bytes, 7858176 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x02444996

Device     Boot Start     End Sectors  Size Id Type
/dev/sdb1  *     2048 7858175 7856128  3.8G  c W95 FAT32 (LBA)
  • You might want to check out this one, might be a similar issue: askubuntu.com/questions/818843/… – bgse Aug 31 '16 at 17:08
  • I followed the link above, but when I type "sudo chroot /mnt" it just says "chroot: failed to run command '/bin/bash': no such file or directory". Also if I type "grub-install /dev/sda" then it says the following: "Installing for i386-pc platform. grub-install: error: can't open directory '/boot/grub/i386-pc': no such file or directory" any tips? – user3252346 Aug 31 '16 at 17:34
  • The chroot command failing with this message indicates there isn't an executable "/bin/bash" inside the changed root. I'd suspect that your partition layout might be different. Go ahead and do a fresh boot to your live session, and then see where your linux installation is, the "fdisk -l" command. Wouldn't hurt to copy/paste that output into your question as the other person did in their question. – bgse Aug 31 '16 at 18:00
  • Done, sorry I forgot about that! Is sda2 Linux filesystem the partition where my linux is installed? It looks different from the other guy's output. – user3252346 Aug 31 '16 at 18:51
  • Yes, your linux filesystem does sit in /dev/sda2 according to your fdisk output, so the step #1 mount command would target this partition. Give me a few minutes, I'll adapt the needed steps to perform for your situation. – bgse Aug 31 '16 at 19:40

Shamelessly stolen from First time installing (erasing Windows) from usb, did everything just so, Boot Device Not Found and adapted to the question.

From an Ubuntu live session, e.g. "Try Ubuntu without installing" from USB-Stick, open a terminal and follow these steps:

1) sudo mount /dev/sda2 /mnt # (If your Linux were on a different partition substitute /sda2 for the partition of your Linux install.)
2) sudo mount /dev/sda1 /mnt/boot/efi # (the efi boot partition)
3) for i in /sys /proc /run /dev; do sudo mount --bind "$i" "/mnt/$i"; done
4) sudo chroot /mnt
5) update-grub

If step 5 throws errors, go ahead with this:

6) grub-install /dev/sda # (/dev/sda is the hard drive that has linux installed (i.e. /dev/sda or /dev/sdb ... etc.)
7) update-grub
  • Thank you for helping, I followed what you said and it did unfortunately not work. I tried doing step 6 as well but still no success. I even tried doing a custom installation from a wiped drive, but still no success.. – user3252346 Aug 31 '16 at 20:26
  • Where did it go wrong? Any error messages or curious output? Or did it appear to work properly, and just the computer still refuses to boot? – bgse Aug 31 '16 at 20:35
  • It appeared to work properly, but still won't boot. "Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported" comes up when I update grub. I tried <askubuntu.com/questions/475993/…> but still no success.. – user3252346 Aug 31 '16 at 21:08
  • That warning message can be safely ignored and should be of no consequence for your issue. Assuming for a moment the process did go as intended, is there maybe some BIOS misconfiguration left from testing out different settings trying to get it to boot? – bgse Aug 31 '16 at 21:17
  • Okay! I don't think so, since it seems to reset all settings when rebooting? I tried to reset do default settings now and it's still the same. I'm a bit lazy and tried to load bios from the command, and it says "grub: Secure boot forbids loading module from (hd0,gpt1)/grub/x86_64-efi/loadbios.mob" Are you supposed to be able to load bios from the usb-command? – user3252346 Aug 31 '16 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.