7

I have a problem with autologin at startup in Ubuntu Server 16.04.1 LTS.

I use this server only for listening internet radio so I do not care about security.

I was able to create a bash script to auto start mplayer but can't configure autologin.

I've tried at least 4 solutions (always editing the file /etc/init/tty1.conf and of course replacing USERNAME with actual user name):

  1. change the line from

    exec /sbin/getty -8 38400 tty1
    

    to

    exec /sbin/getty -8 38400 tty1 -a USERNAME 
    
  2. change the line from

    exec /sbin/getty -8 38400 tty1
    

    to

    exec /bin/login -f USERNAME < /dev/tty1 > /dev/tty1 2>&1
    
  3. Install rungetty, comment the line

    exec /sbin/getty -8 38400 tty1
    

    and add the line

    exec /sbin/rungetty --autologin USERNAME tty1 
    
  4. Install mingetty, comment the line

    exec /sbin/getty -8 38400 tty1
    

    and add the line

    exec /sbin/mingetty --autologin USERNAME tty1
    

Nothing helps - I have to input my login and password at startup - any ideas what to do?

22

Try this:

Create the folder /etc/systemd/system/getty@tty1.service.d

Create the file /etc/systemd/system/getty@tty1.service.d/override.conf

Open the file with your favorite editor and add this:

[Service]
ExecStart=
ExecStart=-/sbin/agetty --noissue --autologin myusername %I $TERM
Type=idle

Replace myusername with your user name.

  • I followed your guide and my machine can log in automatically now. BUT I cannot ssh to the machine as possible before. Please help me to get back to my SSH connection. – Nam G VU Feb 10 '17 at 10:04
  • Hi Nam. Your user have a password? I tried this in a machine and i can access to it over SSH with the user passwd. Shows any error? Thanks. – Jose Carlos Nieto Ramos Mar 3 '17 at 18:46
  • Too long ago and the machine is deleted on my side; sorry I can't get you the error. User has a password of course. – Nam G VU Mar 4 '17 at 11:21
  • 1
    Your guide took me stuck at [OK] Started Update UTMP about System Runlevel Changes. during boot – Patrizio Bertoni Sep 19 '17 at 8:46
  • 2
    Instead of manually creating the .d directory and the override.conf file we can also simply say sudo systemctl edit getty@tty1.service. It will the create the file (if neccessary) and open it an editor. Simply save the file under the suggested name when finished. – PerlDuck Jul 25 '18 at 11:23
2

agetty opens a tty port, prompts for a login name and invokes the /bin/login command.

This file overrides the config by default of agetty on systemd for tty1. This provides a new instance of tty1 with autologin for the user specified.

By the way, the parameter --noissue is used to hide the contents of /etc/issue on login, so not needed in your case.

The option Type=idle found in the default getty@.service will delay the service startup until all jobs are completed in order to avoid polluting the login prompt with boot-up messages. When starting X automatically, it may be useful to start getty@tty1.service immediately by adding Type=simple into the file.

More info: getty: Archlinux.org

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.