13
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
vlc : Depends: vlc-nox (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Depends: libavcodec-ffmpeg56 (>= 7:2.4) but it is not going to be installed or
            libavcodec-ffmpeg-extra56 (>= 7:2.4) but it is not going to be installed
   Depends: libavutil-ffmpeg54 (>= 7:2.4) but it is not going to be installed
   Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
            libgles1
   Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
            libgles2
   Depends: libqt5x11extras5 (>= 5.1.0) but it is not going to be installed
   Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
   Depends: libsdl1.2debian (>= 1.2.11) but it is not going to be installed
   Depends: libva-drm1 (>= 1.1.0) but it is not going to be installed
   Depends: libva-x11-1 (>= 1.0.3) but it is not going to be installed
   Depends: libva1 (>= 1.2.0) but it is not going to be installed
   Depends: libvlccore8 (>= 2.2.0) but it is not going to be installed
   Depends: libxcb-composite0 but it is not going to be installed
   Depends: libxcb-xv0 (>= 1.2) but it is not going to be installed
   Recommends: vlc-plugin-notify (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Recommends: vlc-plugin-samba (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Conflicts: vlc:i386 but 2.1.4-1 is to be installed
vlc:i386 : Depends: vlc-nox:i386 (= 2.1.4-1) but it is not going to be installed
        Depends: libaa1:i386 (>= 1.4p5) but it is not going to be installed
        Depends: libc6:i386 (>= 2.15) but it is not going to be installed
        Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not going to be installed
        Depends: libfreetype6:i386 (>= 2.2.1) but it is not going to be installed
        Depends: libfribidi0:i386 (>= 0.19.2) but it is not going to be installed
        Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
        Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                 libgl1:i386
        Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not going to be installed
        Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
        Depends: libsdl-image1.2:i386 (>= 1.2.10) but it is not going to be installed
        Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not going to be installed
        Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed
        Depends: libtar0:i386 but it is not going to be installed
        Depends: libva-x11-1:i386 (> 1.3.0~) but it is not going to be installed
        Depends: libva1:i386 (> 1.3.0~) but it is not going to be installed
        Depends: libvlccore7:i386 (>= 2.1.0) but it is not installable
        Depends: libx11-6:i386 but it is not going to be installed
        Depends: libxcb-composite0:i386 but it is not going to be installed
        Depends: libxcb-keysyms1:i386 (>= 0.3.9) but it is not going to be installed
        Depends: libxcb-randr0:i386 (>= 1.1) but it is not going to be installed
        Depends: libxcb-shm0:i386 but it is not going to be installed
        Depends: libxcb-xv0:i386 (>= 1.2) but it is not going to be installed
        Depends: libxcb1:i386 (>= 1.6) but it is not going to be installed
        Depends: libxext6:i386 but it is not going to be installed
        Depends: libxinerama1:i386 but it is not going to be installed
        Depends: libxpm4:i386 but it is not going to be installed
        Depends: zlib1g:i386 (>= 1:1.2.3.3) but it is not going to be installed
        Recommends: vlc-plugin-notify:i386 (= 2.1.4-1) but it is not going to be installed
        Recommends: vlc-plugin-pulse:i386 (= 2.1.4-1) but it is not installable
        Conflicts: vlc but 2.2.2+git20160830+r58831+56~ubuntu16.04.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I have tried eveything -f -f install

But nothing seems to work. this is not all when ever i try sudo apt upgrade

I get the following error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 vlc:i386 : Depends: vlc-nox:i386 (= 2.1.4-1) but it is not installed
            Depends: libaa1:i386 (>= 1.4p5) but it is not installed
            Depends: libc6:i386 (>= 2.15) but it is not installed
            Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not installed
            Depends: libfreetype6:i386 (>= 2.2.1) but it is not installed
            Depends: libfribidi0:i386 (>= 0.19.2) but it is not installed
            Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
            Depends: libgl1-mesa-glx:i386 but it is not installed or
                     libgl1:i386
            Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not installed
            Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not installed
            Depends: libsdl-image1.2:i386 (>= 1.2.10) but it is not installed
            Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not installed
            Depends: libstdc++6:i386 (>= 4.6) but it is not installed
            Depends: libtar0:i386 but it is not installed
            Depends: libva-x11-1:i386 (> 1.3.0~) but it is not installed
            Depends: libva1:i386 (> 1.3.0~) but it is not installed
            Depends: libvlccore7:i386 (>= 2.1.0) but it is not installable
            Depends: libx11-6:i386 but it is not installed
            Depends: libxcb-composite0:i386 but it is not installed
            Depends: libxcb-keysyms1:i386 (>= 0.3.9) but it is not installed
            Depends: libxcb-randr0:i386 (>= 1.1) but it is not installed
            Depends: libxcb-shm0:i386 but it is not installed
            Depends: libxcb-xv0:i386 (>= 1.2) but it is not installed
            Depends: libxcb1:i386 (>= 1.6) but it is not installed
            Depends: libxext6:i386 but it is not installed
            Depends: libxinerama1:i386 but it is not installed
            Depends: libxpm4:i386 but it is not installed
            Depends: zlib1g:i386 (>= 1:1.2.3.3) but it is not installed
            Recommends: vlc-plugin-notify:i386 (= 2.1.4-1) but it is not installed
            Recommends: vlc-plugin-pulse:i386 (= 2.1.4-1) but it is not installable
E: Unmet dependencies. Try using -f.

I have tried even the -f but nothing happens still.

Please Help

3
  • 1
    You have tried -f as in sudo apt-get -f install? Because, it's not totally clear from the description you wrote. It's most likely a typo, but I still prefer to ask. Aug 31, 2016 at 9:05
  • Yeah, I had the same issue, and managed to solve with sudo ppa-purge xorg-edgers. I believe this is a specific version of the duplicated question.
    – Atcold
    Mar 31, 2017 at 12:16
  • That 2.2.2+git20160830+r58831+56~ubuntu16.04.1 means you're using a git (testing) version of VLC instead of your distro's default VLC version. Hence, the first step is to remove such repository by running a shell terminal command such as sudo rm /etc/apt/sources.list.d/videolan* (assuming that such repository is owned by Videolan). Afterwards, run the command sudo apt-get purge vlc -y; sudo apt-get autoremove -y; sudo apt-get clean; sudo apt-get update; sudo apt-get check; sudo apt-get dist-upgrade -y; sudo apt-get install vlc -y in order to install your distro's default (stable) VLC. Jul 7, 2017 at 15:41

8 Answers 8

22

The Only Solution to this problem is adding padoka mesa stable repository..

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkppa

Then run

sudo apt-get install vlc

It will Work Surely As the above repository have both libgles1-mesa and libgles2-mesa required for vlc..

5
  • This sure a life saver. I was doing some stuff recently and I needed to use VLC to find out that something else had uninstalled it, and couldn't install again because of libgles1-mesa issues. This such an issue with Debian systems, too many different repos with too many different versions, it's a complete scattering mess when it comes to Debian packages because it likes to break itself.
    – user94959
    Apr 5, 2017 at 5:55
  • 1
    seems to fix the general problem of libgles1-mesa nd libgles2-mesa mutual-exclusivity in 16.04. Jul 31, 2017 at 17:05
  • 1
    Worked perfectly ! Aug 11, 2017 at 7:43
  • Perfect! Solution still works on 16.04.
    – Ricky Dam
    Dec 27, 2017 at 16:24
  • 1
    I added this ppa. Then run the command to install vlc and it is still the same error with dependencies :( Oct 7, 2018 at 17:30
6

Try:

sudo apt-get --purge remove vlc*
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install vlc
3
  • This works - by removing all versions using the (*) then running the commands one by one finally reinstalling again worked for me.
    – Gadgetroid
    Aug 21, 2017 at 23:31
  • I did exactly as recommended here. Spent a lot (!!) of time and it didn't work (the same error with dependencies appear) :( Oct 7, 2018 at 17:19
  • after trying almost everything this is the only solution that worked for me.. thanks!
    – supersan
    Sep 12 at 12:15
3

You can try following the same using the below command

sudo apt-get install aptitude
sudo aptitude install vlc
1

I had exactly the same problem of libraries (cannot install vlc due to issues with libgles1-mesa and libgles2-mesa library dependencies). I could solve the issue using aptitude.

However I could not install vlc right away due to the library dependency issues.

First I had to update libgles1-mesa with $ sudo aptitude install libgles1-mesa

to the question to the proposed solution (keeping non-installed library) answer: NO

then accept the alternative proposal: reverting libgl1-mesa-glx and libglapi-mesa to previous versions

then I went on with libgles2-mesa with: $ sudo aptitude install libgles2-mesa

this time the proposed solution had no issue and installed the library

At this point, I could install vlc with $ sudo apt-get install vlc

and vlc was up and operating Hove it works as well for you!

4
  • 1
    This solution would demand, in my case, removing Skype and Wine. This is not a solution.
    – jfneis
    Jan 28, 2017 at 17:39
  • Same as previous. Seems that the broken dependencies have to do something with xorg-edgers ppa that I'm using. I'll try to remove the ppa.
    – s3v3n
    Mar 2, 2017 at 9:09
  • I've ran ppa-purge ppa:xorg-edgers/ppa, it downgraded a bunch of packages then I was able to install vlc :). Will see if the X still works after a reboot 😂
    – s3v3n
    Mar 2, 2017 at 9:13
  • Possibly related: askubuntu.com/questions/551301/…
    – s3v3n
    Mar 2, 2017 at 9:13
0

Add the PPA for daily pre-release builds of VLC and install it:

sudo add-apt-repository ppa:videolan/master-daily
sudo apt update
sudo apt install vlc

Now open VLC from the Unity Dash (or equivalent app launcher).

5
  • nope still the dependencis coming in Aug 31, 2016 at 9:12
  • are u root user ? Aug 31, 2016 at 9:16
  • yes i am the administrator Aug 31, 2016 at 9:17
  • try to restart the pc and try again : sudo apt update && sudo apt install vlc Aug 31, 2016 at 9:31
  • 1
    i tried it but againa the same error Aug 31, 2016 at 10:03
0

You have 2 options:

  1. Directly install it from "Software Center " . Go to Ubuntu software and type in the search box type "VLC". There you can find the player and you can install it by clicking on Install.

  2. Try the following commands in terminal step by step:

    sudo apt-get update
    sudo apt-get install vlc
    
    sudo apt-get install vlc browser-plugin-vlc (embedded in Mozilla Firefox)
    
13
  • 1
    I tried the software center thing and the install never completes it gets stuck in the starting only. Aug 31, 2016 at 8:17
  • 1
    i tried it and nothing is happening eveny with the above terminal commands that u mentioned Aug 31, 2016 at 8:21
  • Download from link and then dpkg it Aug 31, 2016 at 8:22
  • what is dpkg . i am new to ubuntu Aug 31, 2016 at 8:27
-1

The following commands worked for me:

sudo apt-get update --fix-missing

sudo dpkg --configure -a

sudo apt-get install -f

and then try installing VLC using:

sudo apt install vlc
-1

After a lot of frustration with unmet dependencies, this worked:

sudo add-apt-repository ppa:jonathonf/vlc-3
sudo add-apt-repository ppa:jonathonf/ffmpeg-4
sudo add-apt-repository ppa:jonathonf/meson
sudo apt-get update
sudo apt-get install vlc
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.