0

I've had nvidia-prime together with prime-indicator working when I first set it up.

A few days ago I've installed kernel 4.7; after doing this, I noticed that prime-indicator was showing the nvidia symbol, but actually using Intel graphics. Switching using nvidia-settings wasn't working either.

So, I decided to use bumblebee instead. Removed and purged nvidia* etc. Installed bumblebee like described here. Later, I also tried this method.

In both cases, optirun/primusrun tell me 'Could not load GPU driver'. So, I went to Bumblebee troubleshooting, and it seems like my nvidia .ko files are not present. (bumblebeed: Module 'nvidia' is not found.)

troubleshooting: "Then ensure that you the module is built."

How does one build these kernel modules?


update:

I've tried using dkms autoinstall for my nvidia drivers, this was its output:

Building module:
cleaning build area....
'make' -j8 NV_EXCLUDE_BUILD_MODULES='' KERNEL_UNAME=4.7.0-040700-generic IGNORE_XEN_PRESENCE=1 IGNORE_CC_MISMATCH=1 SYSSRC=/lib/modules/4.7.0-040700-generic/build LD=/usr/bin/ld.bfd modules.....(bad exit status: 2)
ERROR (dkms apport): kernel package linux-headers-4.7.0-040700-generic is not supported
Error! Bad return status for module build on kernel: 4.7.0-040700-generic (x86_64)

So, is my kernel not supported?


My setup: XPS15 9550 laptop, Ubuntu 16.04 on kernel 4.7.0-040700-generic.

  • I've tried using dkms autoinstall for my nvidia drivers, this was its output: Building module: cleaning build area.... 'make' -j8 NV_EXCLUDE_BUILD_MODULES='' KERNEL_UNAME=4.7.0-040700-generic IGNORE_XEN_PRESENCE=1 IGNORE_CC_MISMATCH=1 SYSSRC=/lib/modules/4.7.0-040700-generic/build LD=/usr/bin/ld.bfd modules.....(bad exit status: 2) ERROR (dkms apport): kernel package linux-headers-4.7.0-040700-generic is not supported Error! Bad return status for module build on kernel: 4.7.0-040700-generic (x86_64) So, is my kernel not supported? – Easting Aug 31 '16 at 8:17
  • Bumblebee is depreciated, it is replace by Nvidia-prime. This is a really OTT way to fix an icon glitch. Just roll back the kernel to when it worked, from grub choose advanced options for ubuntu and choose the last working kernel. – Mark Kirby Aug 31 '16 at 9:20
  • In addition to rolling back kernel to last known working version, you can also try updating your 4.7.0 kernel to current version 4.7.2 which might fix the problem. – WinEunuuchs2Unix Aug 31 '16 at 10:58
  • @MarkKirby Aside from the icon problem, the profile was not switching and I wasn't able to get it to work after troubleshooting... – Easting Aug 31 '16 at 11:25
0

Okay, it is working now.

Steps:

  • Completely remove everything that has to do with nvidia, bumblebee and dependencies.
  • Update to kernel 4.7.2 (Not sure if this was the key)
  • Installed nvidia-367 through the additional drivers interface, rebooted.
  • Added ppa:bumblebee/testing.
  • Installed bumblebee, bumblebee-nvidia, primus and prime-indicator through synaptics.
  • Ran sudo prime-select intel and rebooted.
  • Modified /etc/bumblebee/bumblebee.conf, replacing 'current' with '367', rebooted.

Now I can switch globally using prime-indicator or run a specific app using primusrun.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.