36

It appears that upowerd is hogging my cpu time, I killed the process, but it has returned, and is climbing in resource consumption. Do I need upower? can I disable it?

I am using ubuntu Mate 16.04.

heres a screen-shot from the top command enter image description here

  • 18
    Do you happen to have an iPhone plugged into your computer ? If so, you may need to select "Trust this computer" on the phone (or disconnect it), which may fix it: bugs.launchpad.net/ubuntu/+source/upower/+bug/861642 – JonasCz - Reinstate Monica Sep 2 '16 at 6:12
  • 3
    ... why yes, I do, and hey, yeah its fixed! – j0h Sep 2 '16 at 11:49
  • 2
    I have the same problem but I don't have an iPhone plugged in (I don't even have an iPhone!) or any other external device. Only a MicroSD card but upowerd hogs my CPU even with no MicroSD inserted so there must be some other explanation for it. – Vistaus Nov 2 '16 at 15:48
  • 1
    If the question has been answered please mark the answer so that others do not then see it as unanswered – LinuxSailorTech Jan 12 '17 at 14:48
  • @JonasCz Wow, this has been a good day for finding amazingly perfect answers on the first attempt – Hubro Sep 27 '17 at 16:31
47

From @JonasCz, whose comment was:

Do you happen to have an iPhone plugged into your computer ? If so, you may need to select "Trust this computer" on the phone (or disconnect it), which may fix it: bugs.launchpad.net/ubuntu/+source/upower/+bug/861642

Unplugging the Iphone solved the issue, or was an acceptable answer for me.

| improve this answer | |
  • 3
    Thanks, this helped me too! I "trusted" the computer from my iPhone and that fixed it. – Aaron Apr 2 '17 at 13:28
  • 1
    Wow, spot on - ripped out the cable: Gone. Psyhco. Didn't help to kill it either, it just came back. (But @JonasCz should have the credit!) – stolsvik Jul 20 '17 at 20:29
  • 1
    Well that was easy. Crazy stuff... – Tetrinity Jan 17 '18 at 16:51
  • Why iPhone8 can not remember the trust option each time plugged to Ubuntu 16.04? – Honghe.Wu May 18 '18 at 5:42
1

This just happened when I resumed the computer this morning. Going into suspend last night I had Power Panel left open. This morning Power Panel was all greyed out and the hard disk light was flashing like a disco light show.

I used these commands:

$ ps -aux | grep upowerd | grep -v grep
root      2013  0.5  0.0 349976  7372 ?        Rsl  Aug11  11:12 /usr/lib/upower/upowerd

$ sudo killall -9 upowerd

Of course now upowerd isn't running at all but that's OK it'll come back with the next reboot. I don't use it much anyway just to check when wireless mouse or keyboard batteries are low.

| improve this answer | |
0

I had a 3DConnexion device (3D Spacemouse) connected via USB and unplugging it solved my problem CPU hogging problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.