1

I am experiencing many issues that I believe to be linked to my graphics drivers or xorg, not really sure how to pinpoint or fix these issues. Let me start here by listing my system, and then I will give all of my issues.

MSI Z170a Gaming M7 Motherboard Intel 6700k I7 CPU 32 Gigs EVGA DDR4 Ram (3200 Mz) 2 EVGA 980 Ti's run in SLI Samsung 951 Pro M.2 Solid state (256 GB) Running Windows 10 Samsung 850 Pro SATA (256 GB) Running Ubuntu 16.04 2 TB WD Black 7200 RPM for storage (Would like to have both OS share this, but that's another issue for another time)

My hardware as you can see is fairly new (Less than 6 months old), and all works 100% with zero issues in Windows 10. My issues are not faulty hardware related.

Ok to start. Grub loader works flawlessly, and let's me choose between Windows 10 and Ubuntu, incredibly happy about this. However, here is where my first issue arises. I have to go into advanced options for Ubuntu, boot into safe mode, then resume normal boot, otherwise my computer freezes at a purple screen. Once booted to desktop, I must log out, and log back in before my system will run normally. This is incredibly annoying, and I'm hoping fixable.

Upon initial installation, I installed Nvidia drivers, and started setting up my personal flavors for the OS (Desktop BG, installing steam etc). Upon a restart, I started having terrible issues. System would not use my graphics card, resolution was locked at some terribly big and ugly res, second monitor would not turn on etc. I tried for days to search out a solution, and nothing worked. I purged everything nvidia and reinstalled (Using the same method as the first time), and the drivers started working again. However, after a reboot my main monitor would not show, and rendered my computer useless. I had to reboot into safe graphics mode, set to the default config, and reboot.This time it rebooted regularly.

Next issue is sli. Whenever I use the sli on command, I get the following error:

WARNING: Unable to locate/open X configuration file.

Package xorg-server was not found in the pkg-config search path. Perhaps you should add the directory containing `xorg-server.pc' to the PKG_CONFIG_PATH environment variable No package 'xorg-server' found

ERROR: Unable to write to directory '/etc/X11'.

I ran the command as sudo, and it said that it had created the file for me. I manually checked and it listed SLI as being on. However, my second GPU was still not being utilized. I restarted, and again had to boot into safe graphics mode and default the config. At this point, I am lost and would appreciate any and all help. If you would like some reports, please tell me how to get them as I haven't used linux in a very long time, and I would be more than happy to gather those for you.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.