1

We downloaded Ubuntu here http://www.ubuntu.com/download just as prompted. The 64 bit.

We followed howtoubuntu perfectly, using Rufus to put Ubuntu on a new usb stick.

We installed Ubuntu. Everything looked perfect, step by step.

The computer prompted us to restart, so we did.

With the usb stick in, we are prompted to install Ubuntu. Or one time, it started and looked like we were good to go but nothing would open. But when we try to reinstall, we are told the computer already has ubuntu, would we like to install alongside?

Without the usb stick, we are told to install an operating system. "Boot device not found"

You can probably tell by my vernacular that I am not familiar with this process. How can I fix this? Just want to run Ubuntu on the laptop.

Thanks, Tabitha

Edit: this is an hp pavilion laptop, which I could probably tell you more about if I hadn't just deleted everything on it in a failed attempt to use Ubuntu.

Edited to add sudo fdisk -l response:

Disk /dev/sda: 698.7 GiB, 750156374016 bytes, 1465149168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xc9478f8b

Device     Boot      Start        End    Sectors   Size Id Type
/dev/sda1  *          2048 1457870847 1457868800 695.2G 83 Linux
/dev/sda2       1457872894 1465147391    7274498   3.5G  5 Extended
/dev/sda5       1457872896 1465147391    7274496   3.5G 82 Linux swap / Solaris

Partition 2 does not start on physical sector boundary.




Disk /dev/sdb: 57.9 GiB, 62109253632 bytes, 121307136 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x003a2730

Device     Boot Start       End   Sectors  Size Id Type
/dev/sdb1  *     2048 121307135 121305088 57.9G  c W95 FAT32 (LBA)
  • Some more information would probably help figuring out what went wrong. Please edit your question and add the following information if you can: 1) what make/model of laptop is it, e.g. "Dell XPS 13" 2) what is the exact Ubuntu you downloaded, e.g. "14.04 LTS", "desktop variant" 3) did you use 32bit or 64bit Ubuntu – bgse Aug 30 '16 at 20:52
  • From a live session (usb or DVD) type in this command and give us the output: sudo fdisk -l – L. D. James Aug 30 '16 at 20:53
  • In order to type in the command @L.D.James is asking, you will need to open a terminal, the icon in the launcher will look like this: linux-aha.de/wordpress/wp-content/uploads/2014/12/icon_395.png – bgse Aug 30 '16 at 21:01
  • I can't find a command terminal. The only thing close to it is this grub page. I can explore the esc, f9, f10 stuff but nowhere there does it give me the option to open a terminal. If I boot from the usb I can install Ubuntu, but that also doesn't help. – Tabitha O'Melay Aug 30 '16 at 21:18
  • When you boot to the live disk choose "Try Ubuntu". Then you have a full Ubuntu session. You can find the terminal by clicking on the Ubuntu Launch button and tying in terminal. – L. D. James Aug 30 '16 at 21:23
1

From your fdisk -l output you have Linux install in partition /dev/sda1. You need to ensure you have grub installed on that disk and boot to it. You might have to set your bios to boot to your first hard drive. The steps below is to install grub on the your first hard drive using the installed Ubuntu for the installation.

From your live session running these commands, one by one to resolve your issue.

1) sudo mount /dev/sda1 /mnt # (If your Linux were on a different partition substitute /sda1 for the partition of your Linux install.)
2) for i in /sys /proc /run /dev; do sudo mount --bind "$i" "/mnt/$i"; done
3) sudo chroot /mnt
4) update-grub
5) grub-install /dev/sda # (/dev/sda is the hard drive that has linux installed (i.e. /dev/sda or /dev/sdb ... etc.)
    update-grub

Now reboot the system.

If it fails to boot, perform the steps again, but this time be sure to also perform step #5 to install group on the boot drive.

  • ubuntu@ubuntu:~$ sudo mount /dev/sda1 /mnt # ubuntu@ubuntu:~$ for i in /sys /proc /run /dev; do sudo mount --bind "$i" "/mnt/$i"; done ubuntu@ubuntu:~$ sudo chroot /mnt root@ubuntu:/# update-grub Generating grub configuration file ... Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported. Found linux image: /boot/vmlinuz-4.4.0-31-generic Found initrd image: /boot/initrd.img-4.4.0-31-generic Adding boot menu entry for EFI firmware configuration done root@ubuntu:/# – Tabitha O'Melay Aug 30 '16 at 22:22
  • does that look right? do i reboot now or are there errors? – Tabitha O'Melay Aug 30 '16 at 22:23
  • @TabithaO'Melay Yes. That's part of the steps. – L. D. James Aug 30 '16 at 22:25
  • Do I reboot with the usb drive in? – Tabitha O'Melay Aug 30 '16 at 22:32
  • @TabithaO'Melay As per the answer, you have install grup on the hard drive. The first one in the system. You have to make sure you boot to the hard drive. After you boot if you don't see Ubuntu, you might have to go into your bios to make sure you are booting to the first hard drive in your system, which is /dev/sda. – L. D. James Aug 30 '16 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.