By default, syndaemon is called with -i 2.0 -K -R -t. This runs automatically on startup. In previous ubuntus, you could go to the mouse settings and disable the "disable mouse on typing" option, but now in ubuntu 15+, that option seems to have been removed.

How can I disable the default calling of syndaemon so I can run my own non-bugged command in its place?

I should add that this has been prevoiusly reported here.

I have tried putting this in startup applications: sleep 30; killall syndaemon; syndaemon -i .5 -K -R -d, but it doesn't work. I have also tried putting that line in my .profile, but syndaemon seems to be launched after .profile loads.

  • Why the downvotes? Sep 1, 2016 at 19:20
  • If you have an alternative program file and root access, one common solution would be make '/usr/bin/syndaemon' permission to not executable .
    – hunch
    Sep 4, 2016 at 4:30
  • Well, I'm using Ubuntu and here no syndaemon is running!
    – Anwar
    Sep 4, 2016 at 10:00
  • @anwar are you running 15+? If you are running less than 15, do you have disable mouse on typing checked? Sep 4, 2016 at 20:48
  • @Anwar you have to be on a laptop right? My touchpad moves the cursor too with palm movement which is annoying but I use a wireless keyboard and mouse 99.999% of the time so never cared until I read this question. Sep 7, 2016 at 1:55

2 Answers 2


first find the syndaemon executable

which syndaemon

then find which package owns it

dpkg -S /usr/bin/syndaemon 

then list the contents of the package that owns it

dpkg -L xserver-xorg-input-synaptics

have a look at the .conf files listed and you will see the settings you can change.

If you can't find the options you want in there try reading the manual pages listed , these are anything in /usr/share/man and you can view them as follows

man 4 synaptics

This was tested on ubuntu 16.04 and shouldn't be different for other versions

  • in my conf files i can see several options relating to palm detection and disable while typing options.
    – Amias
    Sep 8, 2016 at 9:54
  • this will be systemd service in version newer than 18.X
    – Amias
    Jan 11, 2019 at 14:25

Your idea was right, but the command needs to be a little different:

sh -c "sleep 30; killall syndaemon; syndaemon -i .5 -K -R -d"

This solved the issue for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .