5

When I edit a cell in Libre office Calc, it doesn't clear the old text so all the old letters are left in place, until I click or press return.

A picture tells a thousand words:

in the cell above, I go to the start of the line and put in a new letter

I'm not sure if it is because I have been messing around with my graphics drivers, and updated the kernel to 4.6, and tried the freshers libreoffice ppa with the same results. Any ideas?

uname -a
Linux A 4.6.0-040600-generic #201606100558 SMP Fri Jun 10 10:01:15 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Ubuntu 16.04.1 LTS

apt show libreoffice
Package: libreoffice
Version: 1:5.2.0~rc4-0ubuntu1~xenial2

apt -a show libreoffice-gtk2
Package: libreoffice-gtk2
Version: 1:5.2.0~rc4-0ubuntu1~xenial2

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.2.0
OpenGL core profile shading language version string: 3.30

apt show xfce4 
Package: xfce4
Version: 4.12.2

LO settings - Use hardware accelerationa and use anti-aliasing are set

3
  • 1
    i just solved it by "activating use opengl for all rendering" in options,view
    – Menno
    Dec 4, 2016 at 13:55
  • I have since upgraded to Build ID: 1:5.2.2-0ubuntu2 OS Version: Linux 4.8; UI Render: default; and this issue is resolved (both with intel and nvidea GPUs)
    – Rqomey
    Dec 6, 2016 at 11:42
  • Hit this after updating to LibreOffice 6.0.7.3 (on Windows - google brought me here though) - same solution Tools>Options>View Use OpenGL for all rendering - worked.
    – Ed Randall
    Dec 8, 2018 at 11:10

2 Answers 2

2

I had exactly the same problem and it was driving me crazy... one workaround that worked for me is to set the theme integration to gtk3:

SAL_USE_VCLPLUGIN=gtk3 libreoffice --calc

See Arch Wiki.

1
  • I actually updated to the latest release in the ppa, and that uses gtk3. Also tried fourcing using your command. The problem is a little better now. it refreshes and clears a bit more often. Unfortunately it isn't 100% fixed
    – Rqomey
    Sep 14, 2016 at 12:40
0

After a long time of banging my head against this wall, I just discovered I can solve the problem by removing the Cell freeze in my sheet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .